PDA

View Full Version : Vanilla freezes in Vista after a few seconds


pamperedpeterson
September 18, 2007, 22:52
I am running version 2.93. I have tried opening as administrator, but it never opens that way. I had deleted the lib/pref/font-win file to correct the walls, but it froze, so I put it back and it still freezes. I tried running in compatibility mode, but it still froze.
I tried installing the newer version (3.0.9) but that never opens -- it shows up in the task manager under 'processes' but never under 'applications', and doesn't hide in the 'alt-tab' area. I finally just ended the process, when I found 5 instances but no application. I also tried running in compatibility mode, but no go.
How can I fix this? I need my Angband fix!!! ;)

Bandobras
September 18, 2007, 23:08
Does Wine run under Vista? Or any other emulator? Say, an Amiga emulator... There is so many Angband ports...

pamperedpeterson
September 18, 2007, 23:17
okay, I reveal my true noob-ness here...
what the heck are those? I usually just download the game and play. haha!

Bandobras
September 19, 2007, 00:41
Well, if you play a game compiled for another operating system, you use an emulator. So, for example you can use DosBox, to play a game compiled for DOS under Linux or Windows. Or you use Wine to play a game compiled for Windows XP or earlier on Linux or some other systems (Vista?). If you get hold of Angband binaries and a corresponding emulator, there are chances they will run fine regardless of how exotic your operating system is.

pamperedpeterson
September 19, 2007, 01:25
thx for the explanation. Where would I get an emulator?