PDA

View Full Version : Expand game field


Taickyto
February 20, 2010, 12:40
Hello world :)
I'm brand new here, as the only other rogue-like I've played is adom (which is quite different from any other as far as I know), and before I get totally involved in angband I still have to settle something which is rather annoying :
My playing field is way too small (As you can see there http://img36.imageshack.us/img36/6561/captureul.jpg ) causing some trouble...The map is always scrolling, I don't have a wide view of the map so it's very easy to get lost and every thing like MM, Treasure Detection, Object Detection etc is totally worthless as I detect in a very narrow field. So I'm wondering how I could get the game to fill the whole terminal.

I'm using fedora 12 (constantine) angband 3.0.9 (compiled as I couldn't find a rpm) and xterm (using the gnome terminal don't change a thing)

Any idea ?

Nick
February 20, 2010, 13:23
Adding -- -b to your command line should do it.

Alternatively, you can use the sdl port by
> ./configure --enable-sdl
make
make install
angband -msdl

You may need sudo make install - I can't recall if Fedora uses sudo or not. And you'll need to get the SDL, SDL_mixer, SDL_ttf and SDL_image libraries. But it's a really nice interface once you get it going.

Taickyto
February 20, 2010, 15:23
Yep, it works :D thanks a lot, but isn't it possible to change the font in ASCII mode ? It'd be nice if I had an antialiased one

d_m
February 20, 2010, 15:40
In GCU mode Angband uses whatever font your terminal uses. So if you want to change the font for angband you'll have to change the font for that terminal.

If you have a font you like for Angband but not for general terminal stuff, you could create a shortcut that launches a terminal (e.g. xterm) with a different font and then automatically runs Angband in it.

Taickyto
February 20, 2010, 22:24
Ah yeah it work, the fonts are only a bit weird because of sdl's automatic sizing of fonts :) thank you