PDA

View Full Version : mimic message bug


fizzix
March 24, 2012, 19:44
Came across a strange mimic message while searching a dead-end wall on dlevel 1. Savefile attached.

CunningGabe
March 24, 2012, 20:20
Strange. My guess is that some information is not being wiped or initialized properly. I've made a small change that I think will fix this (and will put in a pullreq soon) -- let me know if you see it again.

fizzix
March 24, 2012, 23:56
If you load up that savefile and search again you can get an error message, "The (nothing) was really a monster" You might have to move down and left one square to trigger it.

CunningGabe
March 25, 2012, 05:54
If you load up that savefile and search again you can get an error message, "The (nothing) was really a monster" You might have to move down and left one square to trigger it.

I'm unable to trigger it, and wasn't able to trigger it before I made the fix either, though I'm not sure whether I searched any squares other than the original one.

fizzix
March 25, 2012, 16:35
So, I played around with it a bit more.

Immediately after the save, if I move diagonally down-left, I get a game crash.

If I move one to the left and then one down and search, I get the bogus mimic message.

CunningGabe
March 25, 2012, 19:01
So, I played around with it a bit more.

Immediately after the save, if I move diagonally down-left, I get a game crash.

If I move one to the left and then one down and search, I get the bogus mimic message.

Which v4 revision?

fizzix
March 26, 2012, 04:13
5e8b222 (dummies to make message long enough)

CunningGabe
March 27, 2012, 00:01
5e8b222 (dummies to make message long enough)
I'm not sure why, but I am unable to reproduce your bug with that revision. Could you try revision 0071e72 or later and see if you still have the same issues?