Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Vanilla (http://angband.oook.cz/forum/forumdisplay.php?f=3)
-   -   A character of mine died (http://angband.oook.cz/forum/showthread.php?t=10020)

sffp May 4, 2020 18:59

A character of mine died
 
But when I open angband this morning to start anew
I get a parsing error referencing column 1 line 1 on the old character's name

Parse error in Brand line 1 column 1

Any way to fix that easily without reinstalling?

sffp May 4, 2020 20:23

1 Attachment(s)
to confuse the matter further -

The background/main screen of angband is showing:
"Initializing brands"

I've tried moving the dead Brand character in the save directory but no joy.

backwardsEric May 4, 2020 20:40

Quote:

Originally Posted by sffp (Post 145191)
to confuse the matter further -

The background/main screen of angband is showing:
"Initializing brands"

I've tried moving the dead Brand character in the save directory but no joy.

Are you using the most recent nightly version? That has a change in the configuration for the brands, though that wouldn't explain why it would stop at the first line of the file.

The file it's complaining about is brand.txt from the lib\gamedata directory within the game's files. If you post the contents of that, it could help determine what went wrong.

backwardsEric May 4, 2020 21:14

What's likely happening is that the game is trying to read the character dump, Brand.txt , as the configuration file for the brands. Moving or renaming that dump - it should be one directory up from the save file you removed - should solve the problem.

DavidMedley May 4, 2020 21:14

I just gotta say, I love the title "A Character of Mine Died."

Nick May 4, 2020 22:07

Quote:

Originally Posted by backwardsEric (Post 145195)
What's likely happening is that the game is trying to read the character dump, Brand.txt , as the configuration file for the brands. Moving or renaming that dump - it should be one directory up from the save file you removed - should solve the problem.

Yes, this should be the correct answer.

I can't believe that when I allowed custom versions of datafiles to be read from the user directory I never saw this problem coming. Now I'm looking through all the datafiles deciding which of them make good character names - I think I like ui_entry_renderer...

sffp May 5, 2020 16:33

That was indeed it. And that was funny.
I do have a character called Ul but sadly not ui_entry_renderer


All times are GMT +1. The time now is 20:13.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.