Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Vanilla (http://angband.oook.cz/forum/forumdisplay.php?f=3)
-   -   Changelog for nightlies (http://angband.oook.cz/forum/showthread.php?t=4307)

myshkin April 12, 2011 09:47

Quote:

Originally Posted by Derakon (Post 51065)
I just tried to jump to dlvl 127 with a wizard and Angband crashed. Console says "Assertion failed: (lev < MAX_DEPTH), function apply_magic, file object/obj-make.c, line 596."

Confirmed and logged as trac ticket #1393. Thanks for the report.

myshkin April 12, 2011 09:53

Quote:

Originally Posted by SSK (Post 51061)
I really liked artifacts having a few more dice on some occasions than the base.

They still do; for example, normal tridents are 1d10, while the Trident of Ulmo is 4d10. It used to be 4d8, but d_m changed it to have the same number of sides as the base weapon.

Quote:

Originally Posted by SSK (Post 51061)
What's weird in the build I am using is that with now TWO weapons, the dice changes reverted randomly to base in the middle of the game!

I have little concept of how this could happen. Do you have a savefile that has one of these weapons?

Magnate April 12, 2011 10:05

Quote:

Originally Posted by Derakon (Post 51062)
That's the second time that bug's been reported, so I guess the devs can't ignore it now. ;)

Sorry, I missed the first time. Is there a savefile anywhere?

(And presumably this isn't caused by the 9th April nightly, if it's been spotted before.)

Hobbels April 12, 2011 10:52

I have posted a savefile here.

http://angband.oook.cz/forum/showthread.php?t=4299

Magnate April 12, 2011 11:42

Quote:

Originally Posted by Hobbels (Post 51084)

Ok thanks, I will look into it. I had about a month off, so missed most of the changes that went into the 9th March nightly, so it will take me a while to work this out. I have absolutely no idea why this should happen, but if I can consistently reproduce the conditions which cause it, it should be possible to figure it out.

Hobbels April 12, 2011 12:58

I lost the extra dice of the dagger Angrist after saving and exiting the game. After loading the dagger had only 1d4. So it's probably an issue with saving and loading.

Magnate April 12, 2011 13:18

Quote:

Originally Posted by Hobbels (Post 51086)
I lost the extra dice of the dagger Angrist after saving and exiting the game. After loading the dagger had only 1d4. So it's probably an issue with saving and loading.

Ah. That makes it a whole lot easier!

Thanks. I will test with your savefile, and others.

myshkin April 12, 2011 15:11

I thought I'd already posted elsewhere on oook, but I guess not. Confirmed and logged as trac ticket #1398.


All times are GMT +1. The time now is 09:27.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.