Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Development (http://angband.oook.cz/forum/forumdisplay.php?f=10)
-   -   [gcu version] strange colors in old variants? the solution is here (http://angband.oook.cz/forum/showthread.php?t=5269)

ghengiz January 27, 2012 23:09

[gcu version] strange colors in old variants? the solution is here
 
First things first, I'm not sure this is already known, I did a search in the old posts but found nothing about the following 'problem', so I thought I could share a simple solution to it, just in case someone else encounters it while testing an old variant on modern systems.

On my xterm-256 colors terminal, some old variants like hellband, zangband, tome 2.3.5, scthangband etc get strange colors if compiled with the default options: for example, the help text is shown in red instead of white.
After a bit of experimentation, I found that simply commenting the line

#define REDEFINE_COLORS

in main-gcu.c and recompiling solves it...

Just trying to be useful :D

Therem Harth January 28, 2012 13:05

Thanks! Not quite a solution, as the colors display wrong in some terminals - red is still shown as bright pink for instance. But most of them are displayed right! Again, thank you.

ghengiz January 28, 2012 13:20

Quote:

Originally Posted by Therem Harth (Post 66454)
Thanks! Not quite a solution, as the colors display wrong in some terminals - red is still shown as bright pink for instance. But most of them are displayed right! Again, thank you.

you're welcome :)
as for the remaining colors, have you already tried to change the color scheme of the terminal?
On my terminal "tango dark" gives the best result, YMMV

Therem Harth January 28, 2012 14:29

Ah, the colors are displayed correctly in an xterm, just not in xfterminal. Thanks again.


All times are GMT +1. The time now is 02:50.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.