Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Vanilla (http://angband.oook.cz/forum/forumdisplay.php?f=3)
-   -   Angband 4.0beta status (http://angband.oook.cz/forum/showthread.php?t=7322)

Nick May 3, 2015 12:39

Angband 4.0beta status
 
I think we're getting pretty close to having a releasable game - thanks everyone for their encouragement and testing.

I have just made another update, 8470954, which fixes:
  • Monster breaths and ball spells being blocked by monsters instead of going over them to hit the player
  • A "mimic woke up" message before the player becomes aware of said mimic (thanks PowerWyrm)
  • Dropping an item on an apparently empty grid with birth_no_stacking set and it disappearing (PowerWyrm again)

As far as I know, there are now 34 bugs that I plan to fix before release. It would be very helpful for people to cast their eyes over that list in order to
  1. See if there is anything I've obviously missed and
  2. If possible indicate any that appear to be already fixed.

Obviously there are things like ID which are only recently fixed; please report any further issues with things like that, or indeed any other bugs you find.

I'm hoping that the next competition can be a 4.0beta one, so we can try to flush out any remaining problems.

Nomad May 3, 2015 13:12

There are a few remaining minor message issues:

Quote:

Originally Posted by Nomad (Post 100904)
* There's still no "You reorder some items in your pack" message when newly identified items are moved to a different inventory slot.
* No "You see no more [items]." message when using consumables from the floor.

Quote:

Originally Posted by Nomad (Post 101039)
Minor message issue I've just noticed with selling items to shops/dropping them into the home. If you sell one of a stack of consumables in your inventory, you get a message like:

Code:

You sold a Scroll of Detect Invisible (f) for 13 gold.
But if you sell a single item/the entire stack at once, you get:

Code:

You sold a Scroll of Detect Invisible () for 13 gold.
I assume the empty parentheses mean it's not checking for the inventory letter until after the item's already gone.

Also some observations I made about existing bugs that might have been missed in the shuffle:

#1889, "Darkness breath removes wall knowledge":

Quote:

Originally Posted by Nomad (Post 100715)
I see from the ticket for #1889, the "Darkness breath removes wall knowledge" bug that people are having difficulty confirming it, so I should volunteer that I get it too, but it only happens if you're standing inside a defined room, not a corridor. (Also, you don't have to wait for a darkness breather, a Scroll or Staff of Darkness will cause the same effect.)

#1892, "Run past objects":

Quote:

Originally Posted by Nomad (Post 100725)
If you stand adjacent to a floor item and run in its direction, instead of moving one square and stopping on top of the item (previous behaviour), you now run two squares and stop in the next square beyond the item. Most significantly, this can cause you to accidentally 'leapfrog' one square outside the trap-detected area if there's an item lying on the detection border.

(I know it's fairly silly and pointless to be using the run command to move a single square anyway, but I tend to just hold shift and keep tapping arrows if I want to run past several obstacles, rather than bother switching back and forth between run and walk.)

Quote:

Originally Posted by Nomad (Post 100836)
If you get a "Your [object] has recharged" message in the same turn that you would have hit the edge of a trap detection boundary while running, you end up running on an extra square and stopping just outside the boundary instead of on it. At least, I think that's what's happening there - I've twice noticed @ running past the edge of a detection area when I got a recharge message. (Possibly other types of messages interrupting running are causing the same issue too? That could be what's behind the intermittent 'run past' bug.)

Nothing else I can think of... in general everything's feeling pretty polished by now, and I actually don't feel like it's appreciably more buggy to play than other major releases when they first arrived. Nice work! :)

Nick May 3, 2015 14:23

That's really useful - #1889 will now be fixed in the next update, and I haven't looked at the others yet.

passer_by May 3, 2015 19:11

Biggest remaining thing I've noticed: if you have quiver slots a) and b) occupied, then drop the contents of a), the quiver does not rearrange.

That is, you end up with slot b) still occupied, and (nothing) in slot a).

Thraalbee May 3, 2015 19:40

When I switch armor, displayed AC in main screen is not updated correctly.
E.g. AC=186 with Adamantite plate, swith to leather and AC=100. Then switch back to the plate and display is still AC=100

Ingwe Ingweron May 4, 2015 01:24

Quote:

Originally Posted by Nick (Post 101107)
....As far as I know, there are now 34 bugs that I plan to fix before release. It would be very helpful for people to cast their eyes over that list in order to
  1. See if there is anything I've obviously missed and
  2. If possible indicate any that appear to be already fixed.
....

Not currently in the bug list:

1. Rebirth issue: character’s name iterates a number (if one was part of the name, e.g, Tester III becomes Tester IV), however, the "player history” description reverts to a random description rather than preserving the former and allowing changes to be made.

2. Message problem when using a macro for activation of a weapon. This was working previously but has now stopped. I use a keymap of “F” for the action: “[A]ctivate [a] principal weapon [5] target”. It works fine if it is not recharging, however, if it is recharging the message seen on the top of the main screen is “Type ? for help.” while the sub-window messages show the proper message “That item is still charging." If instead of using a macro keymap and you manually type in the sequence Aa5 the correct message does appear at the top of the screen.

Ingwe Ingweron May 4, 2015 01:32

Don't know if it's a 4.0 issue or more appropriate to a 4.1 release, but I'd like it if there was some consideration to the issues of using fists. Having a flat damage with no chance of any critical hits, no extra damage from flame, frost or acid gloves, no knowledge of tunneling abilities, etc., were some of the drawbacks noticed when taking up MattB's fists only challenge. See the following thread for a discussion about fists and the effects of equipment.

http://angband.oook.cz/forum/showthread.php?t=7082

Ingwe Ingweron May 4, 2015 02:08

Quote:

Originally Posted by Ingwe Ingweron (Post 101134)
Not currently in the bug list:

....

2. Message problem when using a macro for activation of a weapon. This was working previously but has now stopped. I use a keymap of “F” for the action: “[A]ctivate [a] principal weapon [5] target”. It works fine if it is not recharging, however, if it is recharging the message seen on the top of the main screen is “Type ? for help.” while the sub-window messages show the proper message “That item is still charging." If instead of using a macro keymap and you manually type in the sequence Aa5 the correct message does appear at the top of the screen.

This may also have to to with the reintroduction of a previously squashed bug. In-game messages are clearing instantly (and no, the "clear More prompts" is not activated). Just had the following messages in the sub-window:

"You miss the Brigand.
The Brigand hits you.
The Brigand touches you.
You grab hold of your backpack!
There is a puff of smoke!"

However, in the main window the message line only said: "There is a puff of smoke!" Had to check the message history or the message sub-window to see if any item or money was stolen.

Edit: Also the sound effect was odd, but I can't recall if it was always this way. When the attempted theft occurred there was the sound of coins shuffling, which made me first assume the Brigand had been successful. Shouldn't the sound effect be different for a successful coin theft from an unsuccessful attempted theft, and should the sound also be different if an item was stolen?

Ingwe Ingweron May 4, 2015 02:28

Angband 4.0 dev 8470954

Message and ID by use weirdness continues. And, I didn't see it in the bug list, but maybe I missed it.

"You have no room for a Broad Sword (2d5) {wielded}."

How did it have the "{wielded}" flag when @ hadn't even picked it up, let alone wielded it as equipment?

The same for staves showing up on the floor with the {wielded} flag, even though they never do get wielded since they can't be [e]quipped. In any event, wasn't the message "{tried}" before?

Edit: Just walked over a weapon and got the message, "You have no room for a Long Sword (2d5) {special}." So, maybe some of what I perceived as weirdness is merely a decision to already implement some of the proposed changes to identification. Note that the Phial did not have any strange {appendage} associated with it when @ found it just now.

Ingwe Ingweron May 4, 2015 02:44

Quote:

Originally Posted by Ingwe Ingweron (Post 100468)
....
14. Visual display hesitation when a missile is fired and kills a monster, the monster disappears and then there is a hesitation before the missile appears in the spot it landed.

Didn't find it in the bug list, but it is so trivial that maybe there's no need to bother with it.


All times are GMT +1. The time now is 13:45.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.