Angband Forums

Angband Forums (
-   Idle chatter (
-   -   Problem with sdl 2.0.5 on Ubuntu 16 (

werecobalt November 3, 2019 02:52

Problem with sdl 2.0.5 on Ubuntu 16
Hi! I hope this is the right place for my question.

I want to install libtcod in my computer. It requires sdl 2.0.5. But the hightest version I can install is sdl 2.0.4.

After searching for this problem, I found this thread about installing 2.0.5 on Ubuntu:

After downloading and extracting the tar.gz file from, do I need to put this into the Ubuntu terminal?

tar -zxvf SDL2-2.0.5.tar.gz
cd SDL2-2.0.5
sudo make install
cd ..

I used to make a roguelike on a Windows computer and managed to install libtcod successfully. Now I want to resume on this Ubuntu one. One problem with libtcod itself is that it only has square font. So I also would like to know if there is substitute for libtcod that doesn't require sdl 2.0.5 or has non-square font.

fph November 3, 2019 15:13

Which Linux distribution are you using? It looks like it may be quite outdated.

werecobalt November 3, 2019 16:14

it's ubuntu 16.04 LTS

fph November 3, 2019 20:10

Indeed, that's three and a half years old. Have you considered updating to the next LTS, 18.04?

werecobalt November 4, 2019 01:27

The computer is old too and with Ubuntu 18 it probably will become very slow. Thanks for your help, fph!

The problem, however, is now solved, though I don't quite understand the whole thing.

Yesterday I found out that somehow there was already a libtcod folder in the computer, and I could successfully import libtcod into my code. But in my Windows computer, the line was "import tcod", and it worked, and now the line has to be "import libtcod" to make it work.

All times are GMT +1. The time now is 00:10.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.