Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Development (http://angband.oook.cz/forum/forumdisplay.php?f=10)
-   -   Angband on Ubuntu 12.04? (http://angband.oook.cz/forum/showthread.php?t=6139)

fruviad June 13, 2013 00:41

Angband on Ubuntu 12.04?
 
I have two different Ubuntu 12.04 systems (completely different hardware) that have problems with running Angband.

The first is curses problems, with the screen not being painted properly each turn. I've been using ncurses; reading other posts on the forum leads me to believe that's the best option.

The other problem is "run" not working when holding down the shift key. It works with the period, but I'm too used to the shift-method to learn a new one now. :-(

I get a mix of symptoms, with build configurations generally exhibiting only one of the problems. I've tried compiling 3.4.1, 3.3.2, 3.3.0, and I've tried using the Angband version that Ubuntu pulls down when you install via apt-get.

Has anyone else figured out the magic set of steps needed to get Angband running happily on 12.04?

Hajo June 13, 2013 10:34

I don't know about exactly this Linux version, but in the past I had good success with selfcompiled Angband versions on Linux.

If the curses variant fails, you can still try to compile one of the other backends, like X11 or SDL.

fph June 13, 2013 10:58

I suggest the SDL port.

Magnate June 13, 2013 18:33

Angband runs fine on most Linuxes and I maintain the .deb packages so happy to help out. (Unfortunately I haven't got round to packaging 3.4.x yet, sorry - latest in the repo is 3.3.2)

The 'run' problem is very likely to be to do with prefs/macros and not to do with Linux (unless you're playing via PuTTY or with a weird third-party numpad or something?).

I've not come across the problem you're describing in curses before - could you post a screenshot?

Or, just pick your preferred configuration and post a detailed account of the problems and I'll see if I can reproduce them.

I second the recommendation for the SDL port btw - definitely worth a try.

fruviad June 14, 2013 00:37

Here's a better description (i.e. "corrected") of what I'm seeing. Magnate, if you still want screenshots of a specific config, let me know.

If I use SDL, then all is functional. SHIFT-DIRECTION == "run", and the screen refresh is fine. The look-and-feel doesn't do much for me, though; I prefer the ability to resize windows as offered by X11 & Curses.

If I use X11, then the screen refresh is broken, but SHIFT-DIRECTION works. Interestingly, I was playing with refresh problem in the stores, and I thought I'd started to see a pattern in the repainting problem. I stopped for a minute and stared at the screen while trying to figure it out, and as I stared at the screen my mp3 player (Audacious, fwiw) popped up a small notice above the Angband window telling me what the next song was going to be. This caused the Angband screen to be repainted completely, with all of the missing bits that I'd just triggered with my experimentation from seconds before suddenly appearing.

If I use Curses, then SHIFT-DIRECTION is broken (the UI responds with "Type '?' for help.") but the screen refresh is fine. I'm using libncurses5. I do not have any preferences or macros for the character other than the default, so I'm not sure what to look for.

The results are the same with both 3.4.1 and 3.3.2. The OS is Ubuntu 12.04.

I'd happily put in a few hours' work to get X11 or Curses working if that's what it takes.

All work was done on the console rather than via remote session.

fruviad June 14, 2013 02:23

...and now I *did* just get a screen update problem in SDL when I had it set to 99x36 and 12x20.fon. I haven't found problems with any other SDL settings. It seems to be a bit different from that which I'm seeing in X11.

The X11 rewrite problem is very apparent in stores when arrowing through inventory.

The 99x36 / 12x20.fon SDL configuration was apparent when wandering around in circles in the town, but stores were fine.

This I can repro only in 3.4.1. 3.3.2 is fine.

Magnate June 14, 2013 09:11

Hmmkay. The X11 port has been unmaintained for a long time (it doesn't support tiles), so I'm not sure I can really help there.

Curses should definitely work though. Does dot-run work when shift-run doesn't? I will see if I can reproduce.

fruviad June 15, 2013 02:52

Quote:

Originally Posted by Magnate (Post 81496)
Hmmkay. Curses should definitely work though. Does dot-run work when shift-run doesn't? I will see if I can reproduce.

Dot-run does work. I'm so accustomed to shift-run, however, that trying to adapt to dot-run would drive me nuts.

Magnate June 15, 2013 07:03

Quote:

Originally Posted by fruviad (Post 81522)
Dot-run does work. I'm so accustomed to shift-run, however, that trying to adapt to dot-run would drive me nuts.

So I can reproduce the lack of shift-run in curses, even in the latest dev version. I think you have found a real bug! (I dimly remember this being a regression quite a long time ago, but it was left unfixed for lack of any complaints!)

I'll bring it to d_m's attention as he's the most familiar with the curses code.

fruviad June 16, 2013 21:25

Thanks for following up on this. I thought I was just missing some basic configuration setting...


All times are GMT +1. The time now is 23:02.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.