Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Vanilla (http://angband.oook.cz/forum/forumdisplay.php?f=3)
-   -   Keypad not working with GCU (http://angband.oook.cz/forum/showthread.php?t=6904)

looney August 16, 2014 06:14

Keypad not working with GCU
 
Hi everyone,

I'm getting strange behaviour using the numeric keypad for the GCU interface (the SDL and X11 interfaces work OK). I'm running angband 3.5.0 on Fedora 20 with Cinnamon desktop.

With numlock on:
Run works for left and right movement
Running up and down does nothing at all
Diagonal movement works

With numlock off:
Diagonal movement doesn't work at all ("Press ? for help")
Run does not work in any direction, the character just walks

The numlock key itself is behaving strangely. It takes two keypresses to switch it on, and if I press alt-tab then the alt key, numlock switches off.

I am also running ibus with anthy to enable japanese support. May or may not be part of the problem.

Thanks for any help.

- James

UPDATE - looks like there's an existing problem.

d_m August 18, 2014 04:14

Quote:

Originally Posted by looney (Post 94791)
Hi everyone,
With numlock on:
Run works for left and right movement
Running up and down does nothing at all
Diagonal movement works

With numlock off:
Diagonal movement doesn't work at all ("Press ? for help")
Run does not work in any direction, the character just walks

So, right now the GCU port does not support shift-running. In theory it could probably be redone to support it, but would require some extensive changes. So pressing period and then a direction is the "supported" way to run in GCU.

I think you probably want numlock on in general. There are some hacks to try to support keypad with numlock off but they are not reliable.

Sorry :/


All times are GMT +1. The time now is 22:38.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.