Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Vanilla (http://angband.oook.cz/forum/forumdisplay.php?f=3)
-   -   a few bugs r1176 (http://angband.oook.cz/forum/showthread.php?t=1375)

Faust January 26, 2009 00:51

a few bugs r1176
 
Playing the latest nightly.
Not sure if these are intetional or bugs but thought I'd mention then anyway.

1 tried items are no longer get inscribed {tried}.
2 excellent cursed item pseudo behaves strangly, for example I put on an unID'd negative ring of searching. On the message line it got ID'd as {excellent} then said oops it feels deathly cold, when I looked at my equipment it was inscribed {cursed}.

Faust January 26, 2009 01:50

1 Attachment(s)
(squelch) is being displayed in stores

takkaria January 26, 2009 02:02

Quote:

Originally Posted by Faust (Post 14283)
Playing the latest nightly.
Not sure if these are intetional or bugs but thought I'd mention then anyway.

1 tried items are no longer get inscribed {tried}.

This is fixed, along with (squelch) in stores, in r1180. (The other one isn't, yet.)

Faust January 26, 2009 02:15

That was Quick :)
I'll try it out when I next Die, which knowing my playing style won't be long. :D

CunningGabe January 26, 2009 15:53

I still see (squelch) in stores as of r1180.

takkaria January 26, 2009 15:59

Quote:

Originally Posted by CunningGabe (Post 14318)
I still see (squelch) in stores as of r1180.

Uh, that's because I used binary not instead of logical not. No idea how I managed that, I'm pretty sure I've not done it before... I blame Lua. Fixed in r1182.

Yorick Sha January 27, 2009 16:47

The game (3.1.0) hung up after I read ?ofCreateTrap while standing on Scrolls/Potions shop in town. Just pressed wrong key when I were identifying stuff.

takkaria January 27, 2009 17:00

Quote:

Originally Posted by Yorick Sha (Post 14400)
The game (3.1.0) hung up after I read ?ofCreateTrap while standing on Scrolls/Potions shop in town. Just pressed wrong key when I were identifying stuff.

Known bug, thanks for the report. GabeCunningham fixed it in the development version.

CunningGabe January 27, 2009 17:08

Quote:

Originally Posted by takkaria (Post 14404)
Known bug, thanks for the report. GabeCunningham fixed it in the development version.

Unfortunately, that's premature praise -- I just reported it on Trac. :)

takkaria January 27, 2009 17:18

Quote:

Originally Posted by CunningGabe (Post 14405)
Unfortunately, that's premature praise -- I just reported it on Trac. :)

Oh. Good thing I didn't say you'd staked your reputation on it being fixed, then. :)


All times are GMT +1. The time now is 20:56.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.