Angband Forums

Angband Forums (
-   Vanilla (
-   -   Help with sound (

Sacksquatch December 17, 2020 11:33

Help with sound
Can't get sound to work on 4.2.1.

I run Mint 20, but I have also tried this on Manjaro and MX. Have tried with wine-stable and wine-staging. Weird part is that sound works on Sil, and other RL I launch with wine (Infra Arcana, IVAN, Zorbus, etc) but it refuses to work with Angband, and thus the FAangband beta. I can't even get sound to work on the Angband SDL 2 I compiled a few months ago, which used to work just fine when I ran MX Linux.

Why is Angband the only one I can't get sound for? Sad day.

Any help would be appreciated. Sound is indeed enabled in-game.

Sacksquatch December 17, 2020 13:38

Did a live boot of Manjaro on a different computer, installed wine, fired up angband, enabled sound, still nothing.

Is there a dependency I'm missing?

Nick December 17, 2020 19:55

I suspect it may be a dependency thing - I have trouble getting it to work on OpenSUSE.

Sacksquatch December 18, 2020 00:06

I wonder what happened? It was working a few months ago.

Pete Mack December 18, 2020 00:39

Why use the Windows version on Linux anyway?

Sacksquatch December 18, 2020 01:02

It's not working on my linux compiles either. Though I haven't tried a fresh compile yet, been using ones I made a few months ago.

Sacksquatch December 18, 2020 02:24

Thanks for planting that in my head Pete. A fresh compile, and I'm back in business. I thought maybe it was the sdl2 and dependencies, but the previous compile still doesn't work.

Either way I'm happy, as I have a solution: "just recompile the darn thing".

All times are GMT +1. The time now is 00:21.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.