Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Vanilla (http://angband.oook.cz/forum/forumdisplay.php?f=3)
-   -   [NIGHTLY 12 Feb] Bug crashes Angband on opening (http://angband.oook.cz/forum/showthread.php?t=8265)

bdgamer February 16, 2017 20:54

[NIGHTLY 12 Feb] Bug crashes Angband on opening
 
Was trying out the newest nightly build out of curiosity, and it loaded fine on the first attempt, but each subsequent attempt returns the error:

"Parse error in monster line 10406 column 2"

Nick February 16, 2017 21:02

OK, this looks like it's a problem with the new randart storage system.

The way it now works is to write an 'artifact.txt' file into your user directory, and load from that. Check if you have one of those, an if so, if there's an entry for 'Grond' in it.

Are you playing with randarts?

bdgamer February 16, 2017 21:14

I was attempting to play with the randarts, yes.

So I looked into the user dir for artifact.txt, it was there, but it was completely empty.

I deleted it, and doing so caused the error message to disappear... But, am not sure that any artifacts are actually loaded without the file, based on some of your previous posts.

bdgamer February 16, 2017 21:18

I started a new game, with random artifacts again chosen, and it had the same result. Same error, and same empty artifact.txt in /user.

Nick February 16, 2017 23:14

OK, this is not something I've experienced, I'll have to do more testing.

Which operating system are you playing on, and where are you running Angband from?

bdgamer February 16, 2017 23:32

I am running Windows 10 64-bit, and I ran into that issue with the program running off of a folder on the desktop, as well as in a folder on the C: root.

Nick February 17, 2017 00:41

Thanks, I will test this when I have the chance.

The way I have implemented this seemed very neat and efficient at the time, but I may have made it too fragile.

Nick February 17, 2017 06:50

All right, the problem is just really sloppy programming on my part. I will let you know when the it's is fixed.

Nick February 17, 2017 13:18

New windows build is up, should fix the problem.

bdgamer February 17, 2017 14:56

Nick, I downloaded the updated version, and attempted it, and the same bug still occurred. Blank artifact.txt was created again.


All times are GMT +1. The time now is 04:27.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.