Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Sil (http://angband.oook.cz/forum/forumdisplay.php?f=12)
-   -   Can't get Sil running on Mac (mojave) (http://angband.oook.cz/forum/showthread.php?t=9299)

alandor February 25, 2019 13:50

Can't get Sil running on Mac (mojave)
 
Hi!
I had never heard about Sil until recently but when I read about it I felt like I must try it out. I am a longtime fan of Angband (and Moria before that) and having a setting which is more true to the works of Tolkien sounds very appealing to me.

I downloaded v 1.3 from http://www.amirrorclear.net/flowers/game/sil/ but I can't get that version running on my mac with Mac OS X Mojave. When I launch the program I get this error message:

Code:

Missing resources

Sil was unable to find the 'lib' folder, which should be in the same folder as the application, so must quit. Please report a bug on the Angband forums.

The folder lib is in the same folder as the Sil app. Any ideas on what could be wrong?

Darin February 28, 2019 03:00

Quote:

Originally Posted by alandor (Post 136409)
Hi!
I had never heard about Sil until recently but when I read about it I felt like I must try it out. I am a longtime fan of Angband (and Moria before that) and having a setting which is more true to the works of Tolkien sounds very appealing to me.

I downloaded v 1.3 from http://www.amirrorclear.net/flowers/game/sil/ but I can't get that version running on my mac with Mac OS X Mojave. When I launch the program I get this error message:

Code:

Missing resources

Sil was unable to find the 'lib' folder, which should be in the same folder as the application, so must quit. Please report a bug on the Angband forums.

The folder lib is in the same folder as the Sil app. Any ideas on what could be wrong?

I have the same problem. Tried compiling from source code with no luck. I think Xcode and make couldn't find CarbonSound library.

Since I upgraded to Mojave with my new mac I've been having troubles running Angband variants based off of old codebases. I have been able to get them (including Sil) to run using Crossover with the Windows binaries, so if you don't have that you might try Wine.

wobbly February 28, 2019 03:05

This any help?

http://angband.oook.cz/forum/showthr...Mac#post119355

alandor March 1, 2019 14:09

Found a solution
 
I found a solution just a while after posting this, but it took a while for my post to become active and then I just forgot to check back. All I did was move the Sil application file to another directory and tried to run it from there (which of course gave me the same error). After moving it back to its original folder it could suddenly find the lib folder and would open without a problem.

The other suggestion from wobbly might also work, I never had to try it though.


All times are GMT +1. The time now is 01:28.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.