Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Vanilla (http://angband.oook.cz/forum/forumdisplay.php?f=3)
-   -   Bugs and issues in 4.1.0 (http://angband.oook.cz/forum/showthread.php?t=8432)

Nomad June 26, 2017 14:39

Bugs and issues in 4.1.0
 
Seemed sensible to split off a new thread for this...

Small curse ID bug: treacherous weapon curse is not learned when you get the "Your weapon turns on you" message - you still have to waste an ID scroll to confirm it afterwards.

Mondkalb June 26, 2017 17:27

Well, as already reported, I have no sound (Win 7 home premium 64 bit).
Apparently I am the only one?

wobbly June 26, 2017 17:43

Small flavour bug: Using slow monster while blind tells you the monster "looks" slowed. Also with the staff - 2 monsters look slowed. Maybe it shouldn't be telling me how many monsters are in line of sight.

Nomad June 26, 2017 17:59

Quote:

Originally Posted by Mondkalb (Post 122083)
Well, as already reported, I have no sound (Win 7 home premium 64 bit).
Apparently I am the only one?

I suspect most people just never turn the sound on and wouldn't even notice. Having just checked, turns out I don't have any sound either (also on Win 7 64-bit). Looks like it's been broken for a looong time, too. Checking some random old nightlies that I still have on my machine, I can confirm that the last one I have where the sound still actually works is from March 2016!

Ingwe Ingweron June 26, 2017 18:45

Quote:

Originally Posted by Nomad (Post 122086)
I suspect most people just never turn the sound on and wouldn't even notice. Having just checked, turns out I don't have any sound either (also on Win 7 64-bit). Looks like it's been broken for a looong time, too. Checking some random old nightlies that I still have on my machine, I can confirm that the last one I have where the sound still actually works is from March 2016!

Apart from Angband-Live, which doesn't have sound, I always play with sound on, in every nightly. I'm on OSX, and sound definitely works for me in each nightly all the way through to the newly released 4.1.

wobbly June 26, 2017 20:58

If you inspect elvish waybread it says it heals 4d8 hps. It doesn't

Saplaran June 26, 2017 23:47

1 Attachment(s)
I have here a Whip of Slay Demon (1d3) (+3, +5), average damage/round: 14.3 vs demons, 0 vs. others.

Maybe it should be Clothesline of Slay Demon with this damage. ;)

jowens June 27, 2017 01:30

Arrow keys on a laptop
 
Hi,
I'm on a mac book, and the arrow keys are auto-running, that is I can't move a single space using the arrow keys. It's very frusterating. I went to key maps, and the down arrow key is mapped to `.2`, but when I map it to just `2`, nothing happens.

Gwarl June 27, 2017 01:40

Quote:

Originally Posted by jowens (Post 122098)
Hi,
I'm on a mac book, and the arrow keys are auto-running, that is I can't move a single space using the arrow keys. It's very frusterating. I went to key maps, and the down arrow key is mapped to `.2`, but when I map it to just `2`, nothing happens.

This one is my fault. map it to ;2

Sideways June 27, 2017 02:44

Neither of these issues are new, but I never played 4.0.x or nightlies much, so I didn't notice them before.

The priest prayer Sense invisible has a lower-case i; it should have an upper-case I to be consistent with every other prayer and spell.

Also, in quiver-related prompts (like "fire which ammunition?") the text says "Quiver: a-c" but the slots involved are actually 0, 1 and 2; so either the text should say "Quiver: 0-2" or letters should be allowed as substitutes for digits.

(Yes, finding trivial things to complain about when everybody else is reporting serious bugs is my specialty :))


All times are GMT +1. The time now is 12:35.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.