Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Development (http://angband.oook.cz/forum/forumdisplay.php?f=10)
-   -   Compiling on lubuntu (http://angband.oook.cz/forum/showthread.php?t=10478)

PopTart December 21, 2020 04:25

Compiling on lubuntu
 
Hello, I'm pretty new to Linux, but I managed to compile the game on Lubuntu. Had a heck of a time, since a lot of assumed dependencies weren't there. I ran the following lines:

./autogen.sh
./configure --enable-sdl -enable-x11 ~/Desktop/angband-4.2.1/execute
make
make install

It seems like everything compiled, and I didn't get any errors. So, what's supposed to happen now? It made a new folder called execute, but nothing seems executable in there. I've tried navigating to different folders within the terminal and typing "angband" but nothing works.

Thanks!

PopTart December 21, 2020 05:30

Found it
 
Mysterious... when I navigate to the folder and type "angband", it doesn't work. But when I drag the icon into the terminal, it works.

PopTart December 21, 2020 05:49

Slightly new question
 
When I configured during build, I used these line:

./configure --prefix ~/Desktop/angband-4.2.1/execute --enable-sdl --enable-x11
make
make install

It seems like x11 is working fine, so it works when I put in
/home/lubuntu/Desktop/angband-4.2.1/execute/games/angband -mx11 -- -n5

but when I try to run

/home/lubuntu/Desktop/angband-4.2.1/execute/games/angband -msdl

...I get the error: Unable to prepare any 'display module'!

How do I get SDL to work? Thanks!

PopTart December 21, 2020 06:45

More info: I double checked in my configure step if SDL2 is installed, and yes it is, I installed the main one, the graphics, and the fonts, just no sound.

Another weird thing, in X11, saving the subwindow setup seems to work, but it seems like it's not creating the subwindow file, and when I load it nothing happens, but it doesn't give any error message.

invisibletroll December 21, 2020 13:36

If you install the game, it should run by typing "angband". Otherwise you need to type "./angband".

Type "./configure --help" to get configuration options. Usually you can disable any option you can enable. :rolleyes:

fph December 21, 2020 14:40

If you compiled in SDL2 support, then to activate it you should run Angband with -msdl2. If you use -msdl, it tries to use the older SDL1 backend instead.

Usually when I am compiling I prefer to configure Angband with --with-no-install and then running it from the main compilation folder with "src/angband -msdl2" (or whatever options/backend you wish to use). I suggest to do the same; it is one less thing to do, and it makes it simpler to upgrade to a new version.

invisibletroll December 21, 2020 14:58

Quote:

Originally Posted by fph (Post 150187)
If you compiled in SDL2 support, then to activate it you should run Angband with -msdl2. If you use -msdl, it tries to use the older SDL1 backend instead.

Usually when I am compiling I prefer to configure Angband with --with-no-install and then running it from the main compilation folder with "src/angband -msdl2" (or whatever options/backend you wish to use). I suggest to do the same; it is one less thing to do, and it makes it simpler to upgrade to a new version.

New versions are not released that often. :)

PopTart December 21, 2020 16:05

Quote:

Originally Posted by fph (Post 150187)
If you compiled in SDL2 support, then to activate it you should run Angband with -msdl2. If you use -msdl, it tries to use the older SDL1 backend instead.

Usually when I am compiling I prefer to configure Angband with --with-no-install and then running it from the main compilation folder with "src/angband -msdl2" (or whatever options/backend you wish to use). I suggest to do the same; it is one less thing to do, and it makes it simpler to upgrade to a new version.

Same problem when I use -msdl2. But I will try this no-install option, thank you!

PopTart December 21, 2020 16:05

Quote:

Originally Posted by invisibletroll (Post 150186)
If you install the game, it should run by typing "angband". Otherwise you need to type "./angband".

Type "./configure --help" to get configuration options. Usually you can disable any option you can enable. :rolleyes:

I reconfigured it to install to the default directory, and now it works to simply type angband. Thanks!

PopTart December 21, 2020 17:11

Still not able to make SDL2 work


All times are GMT +1. The time now is 04:51.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.