Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Vanilla (http://angband.oook.cz/forum/forumdisplay.php?f=3)
-   -   Problems running Angband (http://angband.oook.cz/forum/showthread.php?t=633)

ChodTheWacko March 14, 2008 05:23

Problems running Angband
 
Hi Everyone.

I've run Angband on this computer before - I used to download the code & compile it via cygwin with no issues. I stopped for a while when some bugs appeared that I was waiting to get fixed (connected stairs, for example).

Anyway, recently I've had major issues compiling and/or running angband
in windows mode.
1) Main screen appears, text is 'overlapped' and unreadable.
When I try to change font, the game crashes.
I can 'play' it although I can't really read anything. On the character creation screens, I can read whatever line I'm highliting though.

2) I tried nuking everything. Now angband just doesn't start at all.
It hangs - I can see the process running, but nothing appears at all.

I tried downloading and running the nightly builds, too - same issue.

Any insights?
This is windows XP

- Frank

Pete Mack March 14, 2008 07:07

I have no idea why it's not starting up at all, but the horizontally chopped lines are a known bug. To fix it:

1. Copy the 'extended font files' from NPP into your font folder. (They all end in X.fon)
2. Edit main-win.c so that the default font is one of the NPP fonts. (8x12x.fon works fine.)

Something is subtly wrong with the original windows fonts, but it only shows up on some XP installations.

ChodTheWacko March 16, 2008 00:24

Okay, well, this is the weirdest thing I've ever seen.

If I run the binary, and I have a 'command prompt' open, Angband hangs at startup. If I exit all command windows, then it will start.
The hanging Angband will also resume if I exit the command prompt.

So I can do something like:
start -> run -> cmd

in the new command prompt:
F:\Documents and Settings\Frank>cd i:\games\angsrc\trunk
F:\Documents and Settings\Frank>i:
I:\games\angsrc\trunk>start angband

(angband hangs)

I:\games\angsrc\trunk>exit

(command prompt closes and angband pops up!)

- Frank

P.S. Thanks for the help, Pete.

takkaria March 16, 2008 23:28

Quote:

Originally Posted by ChodTheWacko (Post 6495)
Okay, well, this is the weirdest thing I've ever seen.

If I run the binary, and I have a 'command prompt' open, Angband hangs at startup. If I exit all command windows, then it will start.
The hanging Angband will also resume if I exit the command prompt.

So I can do something like:
start -> run -> cmd

in the new command prompt:
F:\Documents and Settings\Frank>cd i:\games\angsrc\trunk
F:\Documents and Settings\Frank>i:
I:\games\angsrc\trunk>start angband

(angband hangs)

I:\games\angsrc\trunk>exit

(command prompt closes and angband pops up!)

- Frank

P.S. Thanks for the help, Pete.

I haven't got a copy of XP at the moment, so I don't know how to help, but this is truly bizarre behaviour. Does this also happen for e.g. 3.0.6 or 2.9.3?

ChodTheWacko March 17, 2008 04:53

Quote:

Originally Posted by takkaria (Post 6503)
I haven't got a copy of XP at the moment, so I don't know how to help, but this is truly bizarre behaviour. Does this also happen for e.g. 3.0.6 or 2.9.3?

Seems to work for 3.0.6.
Happened also for 3.0.9 and 3.0.9a
I don't know if this is worth pursuing, to be honest - much more
important things to work on.
I suspect it has to with the same reasons I'm needing to use the NPP font files in the first place.

I wanted to make the post though, so anyone else who had this problem would know what the workaround is.

- Frank

ChodTheWacko March 17, 2008 05:08

Okay, the command prompt thing only seems to happen if I use the
'x' fonts from NPP. (using latest build: NPP 0.5.0 BETA-6)

Unfortunately if I don't do that, I can't read anything, due to the font overlap.

But the 'close all command prompts' thing gets the game to start.
Pretty wierd stuff.

leeus April 11, 2008 04:18

Quote:

Originally Posted by ChodTheWacko (Post 6449)
Hi Everyone.
<snip> Now angband just doesn't start at all.<snip>

Hi there!

I'm new to this forum, but I wanted to add to this thread that the exact same thing is happening to me, after I upgraded from Vanilla Angband 3.0.6 to the new 3.0.9b. Just registered to reply.

I tried also a fresh installation and it's just the same ...

I'll try to debug the code this weekend, to see if I can find any clue to see what is happening ... I hope I can manage to discover something about it.

I'll have XP also, and since it's already happening to me, maybe I can provide a patch, or attach it to ticket #521 ((I love Trac :D))

Best of regards,
leandro

takkaria January 7, 2011 18:35

Quote:

Originally Posted by ChodTheWacko (Post 6449)
Hi Everyone.

I've run Angband on this computer before - I used to download the code & compile it via cygwin with no issues. I stopped for a while when some bugs appeared that I was waiting to get fixed (connected stairs, for example).

Anyway, recently I've had major issues compiling and/or running angband
in windows mode.
1) Main screen appears, text is 'overlapped' and unreadable.
When I try to change font, the game crashes.
I can 'play' it although I can't really read anything. On the character creation screens, I can read whatever line I'm highliting though.

2) I tried nuking everything. Now angband just doesn't start at all.
It hangs - I can see the process running, but nothing appears at all.

I tried downloading and running the nightly builds, too - same issue.

Any insights?
This is windows XP

- Frank

Do you have a screenshot? Every bug like this is another argument in favour of just using the SDL port...

fizzix January 7, 2011 19:50

Quote:

Originally Posted by ChodTheWacko (Post 6495)
Okay, well, this is the weirdest thing I've ever seen.

If I run the binary, and I have a 'command prompt' open, Angband hangs at startup. If I exit all command windows, then it will start.
The hanging Angband will also resume if I exit the command prompt.

So I can do something like:
start -> run -> cmd

in the new command prompt:
F:\Documents and Settings\Frank>cd i:\games\angsrc\trunk
F:\Documents and Settings\Frank>i:
I:\games\angsrc\trunk>start angband

(angband hangs)

I:\games\angsrc\trunk>exit

(command prompt closes and angband pops up!)

- Frank

P.S. Thanks for the help, Pete.

I cannot reproduce this on Win XP SP3...

ChodTheWacko January 7, 2011 23:34

Quote:

Originally Posted by takkaria (Post 46517)
Do you have a screenshot? Every bug like this is another argument in favour of just using the SDL port...

Here is a screenshot.
I just pulled down a fresh 'git clone' build, compiled it, and ran angband and this is what I see:
http://lishutterbug.com/pics/angband.jpg

If at this point I select another font via window->font->term0, the angband window because as small as possible (i.e. as if I grabbed the lower right corner and made the window as small as possible - you can only see File Window and that's it).

I've had this issue for two years now. I'm currently on windows 7 (which was a clean install, so it's not like I'm still using corrupted xp files). I do have dual monitor if that makes a difference.

My workaround is to use the old NPP fonts, which works for some reason.
It's causing some issues since uniques now use characters not in the old font files, but outside of that, the game runs fine.

The angband hangs issue that was mentioned in the original post was fixed a while back. I believe the game posted a windows message to all the windows and was waiting for a response.

- Frank


All times are GMT +1. The time now is 20:35.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.