Angband Forums

Angband Forums (http://angband.oook.cz/forum/index.php)
-   Vanilla (http://angband.oook.cz/forum/forumdisplay.php?f=3)
-   -   keypad 9 stopped working (http://angband.oook.cz/forum/showthread.php?t=10874)

Latosusi August 15, 2021 07:50

keypad 9 stopped working
 
For some reason keypad 9 does not work anymore. please advice. i was setting up keymaps when that happened. thank you

Estie August 15, 2021 11:43

Have you tried removing a keymap from num-9 ?

Sideways August 15, 2021 12:09

Make sure the 9 key is keymapped to ;9. Also check if [PageUp] is keymapped to ;9, since pressing numpad 9 with numlock off triggers the [PageUp] key instead of the 9 key. If 9 is keymapped to ;9 but [PageUp] isn't, either change the [PageUp] keymap or make sure you always play with numlock on.

If you want to use Shift for running instead of the . key, play with numlock off and check what Shift+[PageUp] is mapped to. It ought to be mapped to .9, but that only matters if you use Shift to run.

Also, make sure you haven't broken your 9 key :)

Latosusi August 15, 2021 14:55

Quote:

Originally Posted by Sideways (Post 154805)
Make sure the 9 key is keymapped to ;9. Also check if [PageUp] is keymapped to ;9, since pressing numpad 9 with numlock off triggers the [PageUp] key instead of the 9 key. If 9 is keymapped to ;9 but [PageUp] isn't, either change the [PageUp] keymap or make sure you always play with numlock on.

If you want to use Shift for running instead of the . key, play with numlock off and check what Shift+[PageUp] is mapped to. It ought to be mapped to .9, but that only matters if you use Shift to run.

Also, make sure you haven't broken your 9 key :)

thank you ;9 helped


All times are GMT +1. The time now is 01:56.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.