View Single Post
Old December 19, 2010, 17:15  
Nomad
Knight
 
Nomad's Avatar
 
Join Date: Sep 2010
Location: England
Posts: 958
Nomad is on a distinguished road
Quote:
Originally Posted by tg122 View Post
I went back to double check the issue I described and can confirm the macros will not work for me in tile mode, and I can get them to work in ASCI mode. However, I just realized that the only way I can get them to work in ASCI mode is if Bigtile mode, double tile mode, and triple tile mode are all unchecked.

To create the macros, I went to options > Interact with macros > create a macro > F1 > pae (pushed enter) > then pushed enter again > append macros to file. I did this 2 more times (F2=pab, F3=paf).

When I hit F1, F2, or F3 in tile mode (or ASCI mode with bigtile, double tile, or triple tile checked), my spell book pops up and it says "recite which prayer"? However, if I go to options > graphics > none, and then I push F1, F2, or F3, it works. If I go back into options > Graphics, and I put a checkmark next to bigtile mode, double tile mode, or triple tile mode, it does not work.

I also can confirm that it happens with a new save fie as well. I have attached my PRF file. Hope this helps.

Edit: Also, if it helps, I'm running windows XP 32 bit.
Huh. Wow. Yep, I can reproduce this (also on Windows) and I stand corrected - it seems to be an entirely separate issue from '@p1' not working. It affects mage casting as well; macro 'mab' to the '#' key and it works fine if bigtile or double/triple tile modes are all off, stalls at selecting the book if any of them are switched on.

The issue still occurs if you use 'm1b' instead of 'mab', and when I tried macroing 'maa' it did select the book but not the spell, suggesting that the second 'a' went through but the first one didn't.

ETA: spell macros work fine in tile mode if bigtile and double/triple are turned off, and the issue doesn't seem to affect other types of inscription-based macros: I macro'd "a1" to the '#' key and that selected the wand inscribed '@a1' quite happily regardless of whether I had bigtile mode on or not.

Good luck tracking this one down, folks...

Last edited by Nomad; December 19, 2010 at 17:27.
Nomad is offline   Reply With Quote