View Single Post
Old March 9, 2008, 05:07   #6
MKula
Apprentice
 
MKula's Avatar
 
Join Date: Feb 2008
Location: Seattle
Posts: 70
MKula is on a distinguished road
Thanks for your help guys! I've made progress!
Turns out you were all correct and I didn't have some some gcc libraries that were needed. Also, I needed to update my autoconf and automake, since I didn't have the correct versions of those either.
The good news: './configure' works now!
The bad news: that's it. 'make' doesn't work.

If I run 'make install' (having run './configure --enable x11') I get the following:
CC main-gcu.c
main-gcu.c:63:22: error: ncurses.h: No such file or directory
main-gcu.c:132: error: expected specifier-qualifier-list before ‘WINDOW’
main-gcu.c: In function ‘Term_xtra_gcu_alive’:
<snip about 50-100 lines>
main-gcu.c:738: error: ‘LINES’ undeclared (first use in this function)
main-gcu.c:738: error: ‘COLS’ undeclared (first use in this function)
main-gcu.c:822: error: ‘stdscr’ undeclared (first use in this function)
make[2]: *** [main-gcu.o] Error 1
make[1]: *** [build] Error 2
make: *** [build] Error 2

Sooo.... what? Apparently main-gcu.c is no good? What's the next step? It's also worth mentioning that even though I ran './configure --enable x11', after all is said and done, the frontends look like:
-- Frontends --
- Curses Yes
- GTK 2.x Disabled
- X11 No; missing libraries
- SDL Disabled

So, even though I explicitly enabled x11, apparently I can't use it because I'm missing libraries? Is that normal?
Your help has been awesome so far; any further advice would be much appreciated! Thanks guys

EDIT: PS Thanks for that link takkaria... I actually feel kind of silly for not realizing it was there, in such an obvious place, since I checked that readme!
MKula is offline   Reply With Quote