View Single Post
Old April 23, 2009, 21:06   #3
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,057
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Quote:
Originally Posted by BlackKnight View Post
To recreate:
- start a character with rantarts enabled in a new savefile
- quit
- restart angband with same save flie
- disable randards and generate new character
- generate an artifact in wizard mode, note random name for standard art
- quit
- start new character (another new savefile) with defaults
- quit
- restart prior character from first save file
- note that standard artifact name is restored
Ok, I can finally recreate this - and we're looking at one bug, not two. When you generate an artifact in wizard mode, check your options (either before or after). You'll notice that randarts are set to Yes, even though they are not actually randomised.

Somehow, un-setting that option during character creation is randomising the artifact names but not the properties. If you unset the option at any time except character creation, it works fine - the next character is generated with normal artifacts.

I think I know why the workaround works: randarts are saved in the savefile, but normal artifacts aren't. So when you reload the savefile, it loads the normal artifacts with their correct names.

No idea why it randomises the names in the first place. Will investigate.
Magnate is offline   Reply With Quote