View Single Post
Old June 2, 2011, 04:32   #92
d_m
Angband Devteam member
 
d_m's Avatar
 
Join Date: Aug 2008
Location: Philadelphia, PA, USA
Age: 41
Posts: 1,516
d_m is on a distinguished road
Quote:
Originally Posted by Derakon View Post
Vaults seem to periodically be missing entire rows of blocks, replaced by empty space. E.g. I found a Bubbles vault that was missing its top row, and I know I've found vaults missing rows through the middle. Don't think I've seen any vaults missing columns. It's actually a bit interesting since it breaks up the flow of the vault, but it's still a bug.
This would be the fault of the function ensure_connectedness() which I've added. It's supposed to ignore "icky" squares to prevent vaults from being mauled, but I definitely believe that it could be messing up somehow.

Do you remember which version of the game generated that level (I assume it was pretty recent)? Also, do you remember how the vault connected with the result of the level? Usually there is a passage leading to some random part of the GV and then the player has to tunnel into it. I've been trying to replicate this without success (so far) so I'm curious if you remember any more details (or maybe even have a screenshot)?

Thanks for your feedback!

EDIT: Of course, after generating 15 Bubbles vaults that are fine (and posting this) I find one that has a column removed! So... clearly I *can* reproduce this. Sorry for the noise
__________________
linux->xterm->screen->pmacs
d_m is offline   Reply With Quote