View Single Post
Old November 3, 2019, 03:52   #1
werecobalt
Rookie
 
Join Date: Jun 2019
Posts: 16
werecobalt is on a distinguished road
Problem with sdl 2.0.5 on Ubuntu 16

Hi! I hope this is the right place for my question.

I want to install libtcod in my computer. It requires sdl 2.0.5. But the hightest version I can install is sdl 2.0.4.

After searching for this problem, I found this thread about installing 2.0.5 on Ubuntu:
https://forum.outpost2.net/index.php?topic=5978.0

After downloading and extracting the tar.gz file from libsdl.org, do I need to put this into the Ubuntu terminal?
Code:
tar -zxvf SDL2-2.0.5.tar.gz
cd SDL2-2.0.5
./configure
make
sudo make install
cd ..
I used to make a roguelike on a Windows computer and managed to install libtcod successfully. Now I want to resume on this Ubuntu one. One problem with libtcod itself is that it only has square font. So I also would like to know if there is substitute for libtcod that doesn't require sdl 2.0.5 or has non-square font.
werecobalt is offline   Reply With Quote