View Single Post
Old February 24, 2021, 12:18   #3
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,060
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Hi fph, many thanks for the feedback. The "4.2.1-commitID-dirty" is because these debs were not built from the exact 4.2.1 tagged commit on github. The eventual released package will be called 4.2.1-debian (or more likely 4.2.2-debian!).

The first set of errors are because the lib/ file structures have changed since 3.5.1 (which is what I presume you were upgrading from, it's the last packaged version), so this is exactly what I needed to know - I will let you know when those are fixed.

The savefile error is I assume because savefiles from 3.5.1 are not readable by 4.2.1 - if that's right then I can't fix this, sorry!
__________________
"3.4 is much better than 3.1, 3.2 or 3.3. It still is easier than 3.0.9, but it is more convenient to play without being ridiculously easy, so it is my new favorite of the versions." - Timo Pietila
Magnate is offline   Reply With Quote