View Single Post
Old February 28, 2021, 22:07   #5
backwardsEric
Swordsman
 
Join Date: Aug 2019
Posts: 308
backwardsEric is on a distinguished road
Installing the packages on Debian Buster with no previously installed Angband package gives:

Code:
dpkg: dependency problems prevent configuration of angband:
 angband depends on libsdl2-2.0.0 (>= 2.0.12); however:
  Version of libsdl2-2.0-0:amd on system is 2.0.9+dfsg1-1
From what I see at packages.debian.org, 2.0.9+dfsg1-1 is the current version of libsdl2-2.0-0 on Debian buster.

If I force the installation (with dpkg --force-depends-version), that works and all three front ends start and will display @ in town. I had to delete a preexisting ~/.angband/Angband/sdl2init.txt file to get the SDL2 front end to start (with the old file there, that front end bailed out with the message,

Code:
parse error in /home/eric//.angband/Angband/sdl2init.txt line 19 column 1: kp-modifier: undefined directive
angband: main-sdl2.c:5646: get_new_window: Assertion '!window->inited' failed.
).
backwardsEric is offline   Reply With Quote