View Single Post
Old July 19, 2018, 15:42   #30
Gwarl
Knight
 
Join Date: Jan 2017
Posts: 602
Gwarl is on a distinguished road
bump because I went and compiled this again on ubuntu (without fancy installaton options this time) and found my own posts here when googling resultant errors.

If you are compiling on Ubuntu, besides what the readme tells you, you'll need gcc-7 (or 6) which isn't available on the Ubuntu xenial repos. To get it:

Quote:
sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-7 g++-7
then use
Quote:
CC=gcc-7 CXX=g++-7 make
The ubuntu section of the Readme.md could maybe use this info.

(note I haven't successfully compiled it yet, will edit when I figure out what else is wrong)

I've tried with 6 and 7 now and double checked I have all the releveant libraries installed and I'm still getting the error I posted before being told my compiler was still too old, argh, can't remember what I did to have this work before

Last edited by Gwarl; July 19, 2018 at 16:05.
Gwarl is offline   Reply With Quote