View Single Post
Old May 14, 2014, 02:20   #1
bron
Swordsman
 
Join Date: May 2008
Location: Saratoga, California (in the midst of Silicon Valley)
Posts: 493
bron is on a distinguished road
Bug with "no artefacts"

My current character is running with no-artefacts turned on, but I just had an artefact get generated anyway:
Code:
   Turn     Depth   Note
      1     50 ft   Challenge: No artefacts
      1     50 ft   (Power)
      1     50 ft   (Versatility)
      1     50 ft   (Flaming Arrows)
      1     50 ft   (Dexterity)
      1     50 ft   (Lore-Keeper)
      1     50 ft   (Lore-Master)
      1     50 ft   (Hardiness) 
      1     50 ft   (Poison Resistance)
      1     50 ft   (Weaponsmith)
      1     50 ft   (Jeweller)
      1     50 ft   (Enchantment)
      1     50 ft   (Artifice)
      1     50 ft   (Song of Slaying)
      1     50 ft   (Song of Aule)
      1     50 ft   (Song of Sharpness)
    711    100 ft   Made a Lesser Jewel of Grace <+1>  0.1 lb
    865    100 ft   Made a Longsword of Doriath (+0,2d5) [+1]  3.0 lb
  1,090    100 ft   Made a Longbow of Nargothrond (+0,2d5)  3.0 lb
  1,186    150 ft   Found The Filthy Rag of Dungalef
There are a number of unusual features of this; I don't know which (if any) are significant:

This is a "45k experience" challenge character, which means I entered "wizard mode" to boost the starting exp. on turn zero.

I set the "no artefacts" flag on turn zero, rather than during character creation.

The artefact came from a chest, rather than being found on the ground.

I got to this point in the game in a continuous run. I had not quit/saved/restarted the character since I set the option.

Checking the "challenge options" menu claims that "no artefacts" is (still) in effect.

I have run a number of no-artefact characters in the past, and have not seen this. I am reasonably certain that all the other times I've played no-artefacts, I set the option during character creation rather than on turn zero, so I'm guessing that's the issue. I have no proof of this however.
bron is offline   Reply With Quote