Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old February 22, 2021, 22:39   #1
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,059
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Debian packages of 4.2.1 for testing

Evening all,

It's been six years, but I have finally built .deb packages for 4.2.1 - if you use Debian, Ubuntu or any other Debian-based Linux, please download them from https://bass.fugue.org/angband/ and install them and try them. Please report any bugs or issues in this thread and not on the Debian or Ubuntu bug trackers - I will not ask for them to be uploaded until they've been tested here.

Unless you want to build from source, the only things you need to download are:

https://bass.fugue.org/angband/angba....1-1_amd64.deb
https://bass.fugue.org/angband/angba....2.1-1_all.deb

You need to install them simultaneously with

sudo dpkg -i angband_4.2.1-1_amd64.deb angband-data_4.2.1-1_all.deb

... or your package manager's equivalent.

Hello to everyone I've not read or replied to in six years - it's been busy! I became a single dad in 2014 and it took a bit of getting used to. I hope you're all well and avoiding COVID.

CC
__________________
"3.4 is much better than 3.1, 3.2 or 3.3. It still is easier than 3.0.9, but it is more convenient to play without being ridiculously easy, so it is my new favorite of the versions." - Timo Pietila

Last edited by Magnate; February 22, 2021 at 23:47.
Magnate is offline   Reply With Quote
Old February 23, 2021, 08:37   #2
fph
Knight
 
Join Date: Apr 2009
Location: Pisa / DL0
Posts: 961
fph is on a distinguished road
Hi and thanks for your work! I tested it on Ubuntu 20.10, overwriting the system package which was already installed. There are some small issues that mostly relate to the upgrade process:

1. During installation I get this warning:
Code:
dpkg: warning: unable to delete old directory '/etc/angband/pref': Directory not empty
dpkg: warning: unable to delete old directory '/etc/angband/edit': Directory not empty
Content of those folders after installation:
Code:
$ ls /etc/angband/pref/
flvr-dvg.prf  font.prf      graf-new.prf  message.prf   xtra-shb.prf
flvr-new.prf  font-sdl.prf  graf-nmd.prf  pref.prf      xtra-xxx.prf
flvr-nmd.prf  font-win.prf  graf.prf      user.prf
flvr-shb.prf  font-x11.prf  graf-shb.prf  xtra-dvg.prf
flvr-xxx.prf  font-xxx.prf  graf-xxx.prf  xtra-new.prf
font-gcu.prf  graf-dvg.prf  keys-gcu.prf  xtra-nmd.prf
$ ls /etc/angband/edit/
artifact.txt  limits.txt        object_base.txt  p_hist.txt         spell.txt
ego_item.txt  monster_base.txt  object.txt       pit.txt            store.txt
flavor.txt    monster.txt       pain.txt         p_race.txt         terrain.txt
hints.txt     names.txt         p_class.txt      room_template.txt  vault.txt
2. When running the game, I got the error "Savefile block can't be read" so I had to delete /var/games/angband/save/Mysavefile.

3. In the help files, the version is described as Angband 4.2.1-g560afcb0-dirty; is that normal?
__________________
Dive fast, die young, leave a high-CHA corpse.
--
You read a scroll labeled 'lol gtfo' of Teleport Level.
fph is offline   Reply With Quote
Old February 24, 2021, 13:18   #3
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,059
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Hi fph, many thanks for the feedback. The "4.2.1-commitID-dirty" is because these debs were not built from the exact 4.2.1 tagged commit on github. The eventual released package will be called 4.2.1-debian (or more likely 4.2.2-debian!).

The first set of errors are because the lib/ file structures have changed since 3.5.1 (which is what I presume you were upgrading from, it's the last packaged version), so this is exactly what I needed to know - I will let you know when those are fixed.

The savefile error is I assume because savefiles from 3.5.1 are not readable by 4.2.1 - if that's right then I can't fix this, sorry!
__________________
"3.4 is much better than 3.1, 3.2 or 3.3. It still is easier than 3.0.9, but it is more convenient to play without being ridiculously easy, so it is my new favorite of the versions." - Timo Pietila
Magnate is offline   Reply With Quote
Old February 24, 2021, 15:52   #4
fph
Knight
 
Join Date: Apr 2009
Location: Pisa / DL0
Posts: 961
fph is on a distinguished road
Quote:
Originally Posted by Magnate View Post
Hi fph, many thanks for the feedback. The "4.2.1-commitID-dirty" is because these debs were not built from the exact 4.2.1 tagged commit on github. The eventual released package will be called 4.2.1-debian (or more likely 4.2.2-debian!).

The first set of errors are because the lib/ file structures have changed since 3.5.1 (which is what I presume you were upgrading from, it's the last packaged version), so this is exactly what I needed to know - I will let you know when those are fixed.

The savefile error is I assume because savefiles from 3.5.1 are not readable by 4.2.1 - if that's right then I can't fix this, sorry!
Thanks! Yes, I agree with you on the diagnosis.

For the savefile, maybe you could (1) move the old savefiles to another folder such as /var/games/angband/oldsave-4.2.1/ , so that the new version runs out of the box, and then (2) warn via webconf during the upgrade process that the old savefiles are not playable anymore and have been moved to that folder as a backup.
__________________
Dive fast, die young, leave a high-CHA corpse.
--
You read a scroll labeled 'lol gtfo' of Teleport Level.
fph is offline   Reply With Quote
Old February 28, 2021, 23:07   #5
backwardsEric
Adept
 
Join Date: Aug 2019
Posts: 116
backwardsEric is on a distinguished road
Installing the packages on Debian Buster with no previously installed Angband package gives:

Code:
dpkg: dependency problems prevent configuration of angband:
 angband depends on libsdl2-2.0.0 (>= 2.0.12); however:
  Version of libsdl2-2.0-0:amd on system is 2.0.9+dfsg1-1
From what I see at packages.debian.org, 2.0.9+dfsg1-1 is the current version of libsdl2-2.0-0 on Debian buster.

If I force the installation (with dpkg --force-depends-version), that works and all three front ends start and will display @ in town. I had to delete a preexisting ~/.angband/Angband/sdl2init.txt file to get the SDL2 front end to start (with the old file there, that front end bailed out with the message,

Code:
parse error in /home/eric//.angband/Angband/sdl2init.txt line 19 column 1: kp-modifier: undefined directive
angband: main-sdl2.c:5646: get_new_window: Assertion '!window->inited' failed.
).
backwardsEric is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling Angband on Debian Wanderlust Vanilla 2 January 13, 2016 12:34
Debian/Ubuntu packages for 3.5.1 Magnate Vanilla 12 February 8, 2015 21:56
any linux packages for 3.4.1 or 3.5? Duskfire Vanilla 4 January 20, 2014 14:17
Angband 3.1.1 available in Debian Magnate Vanilla 5 August 26, 2009 16:50
Testing Timo Pietilš Vanilla 1 April 23, 2007 12:56


All times are GMT +1. The time now is 16:54.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.