Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old August 11, 2019, 23:10   #351
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 54
Posts: 7,830
Donated: $60
Nick is on a distinguished road
Thank you, I have some ideas now.

Quote:
Originally Posted by Saplaran View Post
edit2: "You hear an acrid roar." and again text in the sidebar disappeared... I got the text message but the cone effect didn't show up!
The lack of cone effect is actually due to a missing tile; this one is fixed in development.
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is offline   Reply With Quote
Old August 12, 2019, 02:45   #352
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 54
Posts: 7,830
Donated: $60
Nick is on a distinguished road
Quote:
Originally Posted by Saplaran View Post
It seems to have something to do with -more- prompts and/or lots of fighting in one turn.
I suspect what is happening is that the wrong part of the screen is being wiped when effect animations are displayed. First, some questions:
  • What version of Windows are you using?
  • Are you playing with the default graphics settings? If not, how did you change them?
and could you do some tests for me?
  • Turn the base delay factor right up, and see if you can tell when during an effect animation the sidebar/message is wiped;
  • See if you can see any pattern to what gets wiped by animations on different parts of the screen.
Finally, if you could post a savefile (and randart file if you're using randarts) that would be really helpful.
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is offline   Reply With Quote
Old August 12, 2019, 11:00   #353
Saplaran
Rookie
 
Join Date: Oct 2011
Location: Bavaria, Germany
Posts: 21
Saplaran is on a distinguished road
Quote:
Originally Posted by Nick View Post
[*]What version of Windows are you using?
Windows 10 Pro 1903

Quote:
[*]Are you playing with the default graphics settings? If not, how did you change them?
Yes, I did. In ASCII-Mode the error doesn't occur.

Quote:
and could you do some tests for me?
  • Turn the base delay factor right up, and see if you can tell when during an effect animation the sidebar/message is wiped;
  • See if you can see any pattern to what gets wiped by animations on different parts of the screen.
Finally, if you could post a savefile (and randart file if you're using randarts) that would be really helpful.
Since my character died, I'll start a new character later today and post the results.
Saplaran is offline   Reply With Quote
Old August 12, 2019, 13:40   #354
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 54
Posts: 7,830
Donated: $60
Nick is on a distinguished road
Quote:
Originally Posted by Saplaran View Post
Yes, I did. In ASCII-Mode the error doesn't occur.
Sorry, I wasn't clear. What I meant was: when you were playing with graphics and getting the problems, had you changed any of the settings, or were you just using the ones the game starts with?
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is offline   Reply With Quote
Old August 12, 2019, 14:54   #355
Saplaran
Rookie
 
Join Date: Oct 2011
Location: Bavaria, Germany
Posts: 21
Saplaran is on a distinguished road
You could be right about wiping the wrong parts of the screen. In this save an (invisible) cone hit me the last few turns from the left and the SP in the sidebar got deleted.



Savegame: https://vps.mdiergardt.de/Markus

Walking around while getting hit by the dark hounds should reproduce the bug. Default graphics with "center map continously" enabled.

Last edited by Saplaran; August 12, 2019 at 15:02.
Saplaran is offline   Reply With Quote
Old August 12, 2019, 14:56   #356
Saplaran
Rookie
 
Join Date: Oct 2011
Location: Bavaria, Germany
Posts: 21
Saplaran is on a distinguished road
Quote:
Originally Posted by Nick View Post
Sorry, I wasn't clear. What I meant was: when you were playing with graphics and getting the problems, had you changed any of the settings, or were you just using the ones the game starts with?
I didn't change the graphics settings but only enabled auto-center map.
Saplaran is offline   Reply With Quote
Old August 12, 2019, 19:14   #357
fph
Knight
 
Join Date: Apr 2009
Location: Berlin / Italy
Posts: 781
fph is on a distinguished road
Just a very minor detail: I got these messages while hitting something invisible with an un-IDed Slay Evil weapon:

This doesn't make much sense: if I don't know what I hit, I shouldn't be able to tell what this weapon slays. Also ideally the order of the first two messages should be swapped.
__________________
Dive fast, die young, leave a high-CHA corpse.
--
You read a scroll labeled 'lol gtfo' of Teleport Level.
fph is offline   Reply With Quote
Old August 12, 2019, 23:11   #358
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 54
Posts: 7,830
Donated: $60
Nick is on a distinguished road
Quote:
Originally Posted by Saplaran View Post
Walking around while getting hit by the dark hounds should reproduce the bug. Default graphics with "center map continously" enabled.
Excellent, thanks
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is offline   Reply With Quote
Old August 13, 2019, 19:47   #359
Chud
Swordsman
 
Join Date: Jun 2010
Posts: 284
Chud is on a distinguished road
Minor display bug -- when looking at a monster, it looks like sometimes one of the damage items gets printed in the same color as the screen background, making it unreadable.

I can't reproduce this reliably, but I have seen it several times. I *think* I've only seen it in the description of breath attacks.



This happened to be a great swamp wyrm.

This is one or two builds back from the latest nightly -- baacb2d0c I believe -- on Linux mint 18.
Chud is offline   Reply With Quote
Old August 13, 2019, 21:22   #360
Sphara
Adept
 
Join Date: Oct 2016
Location: Finland
Posts: 189
Sphara is on a distinguished road
I've gotten into a weird situation, what seems to be a bug. I'm standing on a room that has pillars and straight corridors. There's a band of Ologs coming my way but they do not engage, even though the path is not blocked. Ologs stay away one tile between me and them, and they keep moving north and south in front of me, never crossing the melee line. If I cross the line and get next to them, they do not attack, just keep jumping north/south. As if they were curious and afraid at the same time. Ologs in question, were mildly wounded by 2-3 Stinking Clouds but they were not fleeing at any point. Note: these Ologs are a part of Rogrog's gang.

I have noticed the same behavior earlier with Uruks. And notably, Uruks did not use their ranged attack. Just stayed away from melee, not fleeing.

I have game saved in angband.live right in the middle of this weirdness.
Sphara is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
First release Quirk Sil 18 November 14, 2017 23:45
3.4.0 Release Candidate is available fizzix Vanilla 111 July 5, 2012 13:39
3.2 release candidate is upon us! d_m Vanilla 147 January 19, 2011 11:10
Release HellBand 0.8.7 konijn_ Variants 4 December 27, 2009 05:14
reactions to changes in new V release will_asher Vanilla 50 April 9, 2008 19:47


All times are GMT +1. The time now is 23:29.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.