Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Development

Reply
 
Thread Tools Display Modes
Old July 17, 2010, 13:36   #1
TJS
Swordsman
 
Join Date: May 2008
Posts: 473
TJS is on a distinguished road
Error in monsters description

I get an error when trying to run the latest version. It doesn't seem to like the HAS_LITE flag. If I edit it out of the monster.txt I can then get it a bit further, but the game then crashes when you start the game.
TJS is offline   Reply With Quote
Old July 17, 2010, 16:34   #2
d_m
Angband Devteam member
 
d_m's Avatar
 
Join Date: Aug 2008
Location: Philadelphia, PA, USA
Age: 39
Posts: 1,516
d_m is on a distinguished road
Are you building this yourself or using a downloaded nightly build?
__________________
linux->xterm->screen->pmacs
d_m is offline   Reply With Quote
Old July 17, 2010, 16:58   #3
TJS
Swordsman
 
Join Date: May 2008
Posts: 473
TJS is on a distinguished road
Quote:
Originally Posted by d_m View Post
Are you building this yourself or using a downloaded nightly build?
Sorry I should have mentioned that I'm building it myself on Windows.
TJS is offline   Reply With Quote
Old July 17, 2010, 17:34   #4
d_m
Angband Devteam member
 
d_m's Avatar
 
Join Date: Aug 2008
Location: Philadelphia, PA, USA
Age: 39
Posts: 1,516
d_m is on a distinguished road
I think you need to make sure it's a clean build. HAS_LITE is a new flag, which means all the flag macros and such need to run again. I would try doing make clean first and/or a new checkout.

You can also try downloading a nightly to confirm that it's not a bug there.
__________________
linux->xterm->screen->pmacs
d_m is offline   Reply With Quote
Old July 31, 2010, 13:00   #5
TJS
Swordsman
 
Join Date: May 2008
Posts: 473
TJS is on a distinguished road
I think I've been doing the make clean incorrectly. When I try this:

nmake /fMakefile.nmake clean

I get this error:

NMAKE : fatal error U1077: 'del' : return code '0x1'

Not to matter though, I've deleted everything in my angband folder and grabbed again and it seems to be working fine.
TJS is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Serious problem with Aeglos description ClaytonAguiar Vanilla 2 May 26, 2010 20:15
Death mold description bug? Rizwan Vanilla 3 June 22, 2009 07:30
Feature request: Price in description ClaytonAguiar Vanilla 7 May 31, 2009 22:47
SAngband Error Prismatic Variants 20 May 20, 2008 18:26
Changing personal description Cardinal Rob Vanilla 1 April 3, 2008 14:39


All times are GMT +1. The time now is 08:47.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.