Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old December 17, 2020, 12:33   #1
Sacksquatch
Rookie
 
Join Date: Jun 2020
Posts: 24
Sacksquatch is on a distinguished road
Help with sound

Can't get sound to work on 4.2.1.

I run Mint 20, but I have also tried this on Manjaro and MX. Have tried with wine-stable and wine-staging. Weird part is that sound works on Sil, and other RL I launch with wine (Infra Arcana, IVAN, Zorbus, etc) but it refuses to work with Angband, and thus the FAangband beta. I can't even get sound to work on the Angband SDL 2 I compiled a few months ago, which used to work just fine when I ran MX Linux.

Why is Angband the only one I can't get sound for? Sad day.

Any help would be appreciated. Sound is indeed enabled in-game.

Last edited by Sacksquatch; December 17, 2020 at 13:13.
Sacksquatch is offline   Reply With Quote
Old December 17, 2020, 14:38   #2
Sacksquatch
Rookie
 
Join Date: Jun 2020
Posts: 24
Sacksquatch is on a distinguished road
Did a live boot of Manjaro on a different computer, installed wine, fired up angband, enabled sound, still nothing.

Is there a dependency I'm missing?
Sacksquatch is offline   Reply With Quote
Old December 17, 2020, 20:55   #3
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 55
Posts: 8,657
Donated: $60
Nick will become famous soon enough
I suspect it may be a dependency thing - I have trouble getting it to work on OpenSUSE.
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is offline   Reply With Quote
Old December 18, 2020, 01:06   #4
Sacksquatch
Rookie
 
Join Date: Jun 2020
Posts: 24
Sacksquatch is on a distinguished road
I wonder what happened? It was working a few months ago.
Sacksquatch is offline   Reply With Quote
Old December 18, 2020, 01:39   #5
Pete Mack
Prophet
 
Join Date: Apr 2007
Location: Seattle, WA
Posts: 5,989
Donated: $40
Pete Mack is on a distinguished road
Why use the Windows version on Linux anyway?
Pete Mack is online now   Reply With Quote
Old December 18, 2020, 02:02   #6
Sacksquatch
Rookie
 
Join Date: Jun 2020
Posts: 24
Sacksquatch is on a distinguished road
It's not working on my linux compiles either. Though I haven't tried a fresh compile yet, been using ones I made a few months ago.
Sacksquatch is offline   Reply With Quote
Old December 18, 2020, 03:24   #7
Sacksquatch
Rookie
 
Join Date: Jun 2020
Posts: 24
Sacksquatch is on a distinguished road
Thanks for planting that in my head Pete. A fresh compile, and I'm back in business. I thought maybe it was the sdl2 and dependencies, but the previous compile still doesn't work.

Either way I'm happy, as I have a solution: "just recompile the darn thing".
Sacksquatch is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
v4.1.2 Sound? Imzy Vanilla 1 January 27, 2018 23:45
Sound/Message Use TricksterWolf Development 11 November 4, 2013 06:36
Sound? Quinn13 Vanilla 4 March 3, 2013 10:08
linux sound? runequester Vanilla 8 April 22, 2012 23:42
Probably going to sound stupid Monkay Vanilla 6 March 20, 2012 14:16


All times are GMT +1. The time now is 14:25.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.