Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old May 3, 2011, 13:22   #1
Gockel
Apprentice
 
Join Date: Aug 2010
Posts: 69
Gockel is on a distinguished road
macro issue

i have a problem with inscriptions in 3.2.0... not sure if anyone else addressed this already:

i switched to roguelike keyset lately, which means "a" zaps rods, "z" aims wands. but if i want to create a macro i still have to use "z" for zapping a rod and "a" to aim a wand like in the original keyset.
now that i know of it it's no problem, just thought i'd mention it in case it hasn't been addressed yet.

also there's one slightly annoying thing. it happens sometimes that i forget the letter in inscriptions (@1 instead of @z1). whenever this happens pressing shift-x after the inscription was made will crash angband... not a big issue of course, i should just start paying attention a bit, and i'm not sure why i mention it at all but i do...
Gockel is offline   Reply With Quote
Old May 3, 2011, 23:23   #2
myshkin
Angband Devteam member
 
Join Date: Apr 2007
Posts: 334
myshkin is on a distinguished road
Quote:
Originally Posted by Gockel View Post
i have a problem with inscriptions in 3.2.0... not sure if anyone else addressed this already:

i switched to roguelike keyset lately, which means "a" zaps rods, "z" aims wands. but if i want to create a macro i still have to use "z" for zapping a rod and "a" to aim a wand like in the original keyset.
now that i know of it it's no problem, just thought i'd mention it in case it hasn't been addressed yet.
When you say, "want to create a macro," I assume you are talking about inscriptions, given your introduction. This is indeed known, if poorly documented, behavior. takkaria has done a lot of work on the keymap system since 3.2.0; I might guess that we will have better documentation for it before 3.3.0.

Quote:
Originally Posted by Gockel View Post
also there's one slightly annoying thing. it happens sometimes that i forget the letter in inscriptions (@1 instead of @z1). whenever this happens pressing shift-x after the inscription was made will crash angband... not a big issue of course, i should just start paying attention a bit, and i'm not sure why i mention it at all but i do...
This bug was previously reported elsewhere in the forums, noted in trac, and fixed a couple months ago.
myshkin is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tunneling macro help... Skitzman69 Vanilla 3 April 30, 2012 06:39
Macro difficulty stabbo Vanilla 16 November 18, 2010 08:16
NPP issue Jungle_Boy Variants 4 March 26, 2010 18:45
Has your issue been reported already? Magnate Vanilla 13 July 26, 2009 23:42
Z+ known issue Mangojuice Variants 0 November 19, 2008 22:26


All times are GMT +1. The time now is 11:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.