Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old December 29, 2010, 06:53   #41
molotov
Rookie
 
Join Date: Dec 2010
Posts: 6
molotov is on a distinguished road
The color option seems to work now. I found a unique and switched it off then on and he changed to pale violet. Maybe something changed on my install of Angband between yesterday and today, but now I can't replicate the problem.

Thanks for all your help, and now I look forward to pressing on into the world of randarts!
molotov is offline   Reply With Quote
Old December 29, 2010, 09:49   #42
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,060
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Quote:
Originally Posted by buzzkill View Post
Hmm. I'll have to check. I just copied my 3.1.2 ini into the 3.2 folder and everything looked OK when the game started. <goes to check>

OK, using Windows (Vista), David Gervais 32x32 tiles, Double Tile and Big Tile both on. Both 'enable nice graphics' and 'bizarre display' seem to have no effect and in any case don't affect the glitch. Deleting the ini didn't help either. This glitch does not occur in ASCII mode.

The glitch (yellow box outline) only persists in the black (unexplored) areas of the map, and even then then a font sized??? (8x12???) chunk of it is missing from the upper left corner. So it appears at least part of the box is being erased.
Ok, it's a bigtile glitch - there are a bunch of these, which should be fixed in 3.3, we hope. Glitches with 1x1 tiles are a bigger worry ...
Quote:
Just as the spells do, at the bottom of the list, underneath the last item. There's plenty of room, at least on my screen.
Ah, that would be difficult, since the menu code uses up all the available space on smaller main windows. Also, the object inspection code can take over 24 lines in some cases! Worth thinking about though - my suggestion would be that it appeared in the "object recall" subwindow.
Quote:
At the very end of character creation there is a press "['ESC' to step back, 'S' to start over, or any other key to continue]" How about just adding "or 'B' to set birth options" to it (or =).
Yes, excellent idea - now ticket #1295.
Magnate is offline   Reply With Quote
Old December 29, 2010, 09:52   #43
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,060
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Quote:
Originally Posted by molotov View Post
The color option seems to work now. I found a unique and switched it off then on and he changed to pale violet. Maybe something changed on my install of Angband between yesterday and today, but now I can't replicate the problem.

Thanks for all your help, and now I look forward to pressing on into the world of randarts!
Glad it's sorted now - admittedly the "light violet" isn't the most striking colour. But you can intensify it by going to the "interact with colours" option in the options menu and changing the RGB values if you want.
Magnate is offline   Reply With Quote
Old December 29, 2010, 19:27   #44
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,060
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Quote:
Originally Posted by pampl View Post
I can't seem to identify = of the dog to find out their (+,+) values.. I have to sell them to learn. Also, magical armors don't display their to hit penalty. Other than that, though, great release.
Thanks. I can't reproduce the =Dog problem - they ID fine for me. Or do you mean they don't ID by use? I can't reproduce that either - one hit and the hit/dam bonuses show up.

The other one was deliberate: it's not that to-hit penalties aren't showing, it's that they aren't there any more on ego armour. This was a while ago, but IIRC it was an unintended side-effect of the new code to check for minimum to-hit/dam bonuses on certain egos (mainly launchers of accuracy/power). There was a good thread debating it and in the end we decided we quite like the idea that ego armour had this additional small advantage. Normal and "magical" armours still have the penalties, it's only ego armour that doesn't.

P.S. Since the whole issue of penalties for wearing heavy armour is on our list of things to look at, we decided it wasn't worth "fixing" this issue. After fizzix releases a playable version with the new evasion/absorption combat model, the next combat-related changes are critical hits and armour penalties ...
Magnate is offline   Reply With Quote
Old December 29, 2010, 21:38   #45
pampl
RePosBand maintainer
 
Join Date: Sep 2008
Location: Seattle, WA, USA
Posts: 225
pampl is on a distinguished road
Quote:
Originally Posted by Magnate View Post
Thanks. I can't reproduce the =Dog problem - they ID fine for me. Or do you mean they don't ID by use? I can't reproduce that either - one hit and the hit/dam bonuses show up.

The other one was deliberate: it's not that to-hit penalties aren't showing, it's that they aren't there any more on ego armour. This was a while ago, but IIRC it was an unintended side-effect of the new code to check for minimum to-hit/dam bonuses on certain egos (mainly launchers of accuracy/power). There was a good thread debating it and in the end we decided we quite like the idea that ego armour had this additional small advantage. Normal and "magical" armours still have the penalties, it's only ego armour that doesn't.
I can't recreate most of the bugs I thought I was experiencing so I'll have to wait until/if they happen again and upload a save. One that I can recreate is the = of the Dog ID problem: once you recognize their flavor, they stop being a valid target for ID. ID by use still seems to work though.

Also, new bug: creating an item in wiz mode doesn't redraw the screen, even if the item is created somewhere it should be immediately visible- i.e. it's not created at the player's feet because he's standing on the stairs.
pampl is offline   Reply With Quote
Old December 29, 2010, 21:55   #46
d_m
Angband Devteam member
 
d_m's Avatar
 
Join Date: Aug 2008
Location: Philadelphia, PA, USA
Age: 41
Posts: 1,516
d_m is on a distinguished road
Quote:
Originally Posted by pampl View Post
Also, new bug: creating an item in wiz mode doesn't redraw the screen, even if the item is created somewhere it should be immediately visible- i.e. it's not created at the player's feet because he's standing on the stairs.
I've seen this bug before, and it's worth reporting, but I consider it a lower priority than the game play bugs that affect regular users
__________________
linux->xterm->screen->pmacs
d_m is offline   Reply With Quote
Old December 29, 2010, 22:04   #47
juggle5
Scout
 
Join Date: Feb 2009
Posts: 30
juggle5 is on a distinguished road
I'm enjoying 3.2, but I'm getting an annoying crash (running Mac OS X 10.6).

I'm using the roguelike keyset, and have my magic books inscribed as @1, @2, etc. If I type 'm 2' to cast a spell from the second book, the game crashes, though typing 'm b' works fine, as does 'm 1' (to cast from the first book).

I've attached my save file (compressed).

Here's the information from gdb:
Code:
Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000008
0x0000ab87 in cmd_lookup ()
(gdb) bt
#0  0x0000ab87 in cmd_lookup ()
#1  0x0005f83b in get_item ()
#2  0x0009be86 in textui_obj_cast ()
#3  0x0000b2d7 in textui_process_command ()
#4  0x000aa4fe in textui_get_cmd ()
#5  0x000b65bb in crb_get_cmd ()
#6  0x00020406 in cmd_get ()
#7  0x000209a0 in process_command ()
#8  0x00016668 in dungeon ()
#9  0x0001730a in play_game ()
#10 0x000b595f in AngbandGame ()
#11 0x9489ff2f in DispatchEventToHandlers ()
#12 0x9489f1f6 in SendEventToEventTargetInternal ()
#13 0x9489f055 in SendEventToEventTargetWithOptions ()
#14 0x948d3bb0 in ToolboxEventDispatcherHandler ()
#15 0x948a0380 in DispatchEventToHandlers ()
#16 0x9489f1f6 in SendEventToEventTargetInternal ()
#17 0x948c19bb in SendEventToEventTarget ()
#18 0x94a4acc3 in ToolboxEventDispatcher ()
#19 0x94a4adfb in RunApplicationEventLoop ()
#20 0x000b7b0d in main ()
Attached Files
File Type: zip Dalluini.zip (7.2 KB, 198 views)
juggle5 is offline   Reply With Quote
Old December 29, 2010, 22:39   #48
d_m
Angband Devteam member
 
d_m's Avatar
 
Join Date: Aug 2008
Location: Philadelphia, PA, USA
Age: 41
Posts: 1,516
d_m is on a distinguished road
Quote:
Originally Posted by juggle5 View Post
I'm enjoying 3.2, but I'm getting an annoying crash (running Mac OS X 10.6).
Ouch!

I will definitely take a look at this as soon as I can.

Seems like we might need 3.2.1 sooner than we thought :P
__________________
linux->xterm->screen->pmacs
d_m is offline   Reply With Quote
Old December 30, 2010, 00:05   #49
awldune
Adept
 
Join Date: Dec 2007
Posts: 113
awldune is on a distinguished road
Quote:
Originally Posted by Magnate View Post
Glad it's sorted now - admittedly the "light violet" isn't the most striking colour. But you can intensify it by going to the "interact with colours" option in the options menu and changing the RGB values if you want.
Please consider changing the default "light violet" color -- I thought "purple uniques" wasn't working because I was expecting to see the same violet color that most of the uniques were in 3.1.x.

I am red/green color deficient and find the default light violet indistinguishable from grey. Something like FF30FF is much more distinct while still distinguishable from the other pink/purple colors.

Thanks!

I also have had some glitches with text being displayed offscreen on Windows. It seems to go away after saving/reopening, so maybe an issue with angband.ini?

Otherwise I am excited about the feature changes and look forward to trying out 3.2 some more.
awldune is offline   Reply With Quote
Old December 30, 2010, 09:55   #50
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,060
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Quote:
Originally Posted by awldune View Post
Please consider changing the default "light violet" color -- I thought "purple uniques" wasn't working because I was expecting to see the same violet color that most of the uniques were in 3.1.x.
Not using that colour was a deliberate choice.
Quote:
I am red/green color deficient and find the default light violet indistinguishable from grey. Something like FF30FF is much more distinct while still distinguishable from the other pink/purple colors.
That's a very helpful suggestion - thank you. I'll try that out.
Quote:
I also have had some glitches with text being displayed offscreen on Windows. It seems to go away after saving/reopening, so maybe an issue with angband.ini?
Sorry, not sure about this one.

Just to clarify for all the people out there who might notice odd little visual quirks with 3.2 - there are two key issues to resolve before reporting any bugs for this type of issue:

1. Does it happen when you switch off graphical tiles and just play with ascii? Even if you never play with ascii, please check this before reporting the bug as it will be helpful in tracing it.

2. Does it happen only with any kind of "bigtile" mode (i.e. if tile_width or tile_height > 1), or does it happen with normal-sized tiles? Again, it will be very helpful if you can answer this for us.

Thanks.
Magnate is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Angband 3.1.2 released! takkaria Vanilla 21 February 7, 2010 23:39
Angband 3.1.1 released takkaria Vanilla 107 September 24, 2009 04:56
Z+Angband 0.2.3 released Mangojuice Variants 58 October 29, 2008 20:37
Angband 3.0.9b released. takkaria Vanilla 3 April 12, 2008 12:58
Angband 3.0.9 released takkaria Vanilla 18 August 8, 2007 04:30


All times are GMT +1. The time now is 17:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.