Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Sil

Reply
 
Thread Tools Display Modes
Old January 6, 2013, 12:53   #1
dixius99
Rookie
 
Join Date: Jan 2013
Posts: 5
dixius99 is on a distinguished road
Question Sil 1.1.1 control on Mac OS X

Not sure if this is an issue on my machine, but thought I would report it anyway...

Just trying the tutorial for Sil 1.1.1, and the instructions to, for example, hold Control and press a direction to break down a door don't work. I've tried Command instead, and also tried Fn-Command, Fn-Control, Option-Control, Shift-Control, etc, pretty much every one of those types of keys and combinations I could think of, but no success. Pressing / and then the direction does work though.

Could this be because I'm on a MacBook Pro, and the modifier keys aren't working correctly in Sil?
dixius99 is offline   Reply With Quote
Old January 6, 2013, 19:39   #2
half
Knight
 
half's Avatar
 
Join Date: Jan 2009
Posts: 904
half is on a distinguished road
Quote:
Originally Posted by dixius99 View Post
Not sure if this is an issue on my machine, but thought I would report it anyway...

Just trying the tutorial for Sil 1.1.1, and the instructions to, for example, hold Control and press a direction to break down a door don't work. I've tried Command instead, and also tried Fn-Command, Fn-Control, Option-Control, Shift-Control, etc, pretty much every one of those types of keys and combinations I could think of, but no success. Pressing / and then the direction does work though.

Could this be because I'm on a MacBook Pro, and the modifier keys aren't working correctly in Sil?
Thanks for reporting this dixius99. Which version of OS X are you using?

Scatha: does this work for you on your MacBook Pro?
half is offline   Reply With Quote
Old January 7, 2013, 11:39   #3
dixius99
Rookie
 
Join Date: Jan 2013
Posts: 5
dixius99 is on a distinguished road
10.8.2

I thought it might be my language settings (Canadian English), but I changed to US English and it's the same thing.
dixius99 is offline   Reply With Quote
Old January 7, 2013, 11:55   #4
half
Knight
 
half's Avatar
 
Join Date: Jan 2009
Posts: 904
half is on a distinguished road
Thanks. I'm still on 10.6 on my development machine, but I'll look into this when I upgrade. Until then, best to stick to (/).
half is offline   Reply With Quote
Old January 7, 2013, 17:10   #5
Scatha
Swordsman
 
Join Date: Jan 2012
Posts: 414
Scatha is on a distinguished road
Tested, and I have the same problem. Control+direction seems to be reserved by the os for switching windows. I don't know if this is a mac book pro issue or just the version of the os.
Scatha is offline   Reply With Quote
Old January 7, 2013, 17:31   #6
jujuben
Apprentice
 
Join Date: Jan 2012
Posts: 56
jujuben is on a distinguished road
I'm running 10.6.8 on a mid 2009 Macbook Pro, and it works fine for me.
__________________
A soft answer turneth away wrath. Once wrath is looking the other way, shoot it in the head.
--The Seven Habits of Highly Effective Pirates
jujuben is offline   Reply With Quote
Old January 7, 2013, 20:44   #7
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 54
Posts: 7,984
Donated: $60
Nick will become famous soon enough
Quote:
Originally Posted by Scatha View Post
Tested, and I have the same problem. Control+direction seems to be reserved by the os for switching windows. I don't know if this is a mac book pro issue or just the version of the os.
It may depend on whether you have Spaces (the OSX desktop switcher) activated, and how many spaces you have allocated.
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is offline   Reply With Quote
Old January 7, 2013, 21:09   #8
half
Knight
 
half's Avatar
 
Join Date: Jan 2009
Posts: 904
half is on a distinguished road
Quote:
Originally Posted by Nick View Post
It may depend on whether you have Spaces (the OSX desktop switcher) activated, and how many spaces you have allocated.
Ah, this is probably right. The default key combination for switching desktops is Control-Arrow Key. So Control-Keypad should work, except you don't have a keypad. In the future I'll consider a work around for this. For now, you could change the key combination for changing desktops in System Preferences (may not be worth it for you...) or use '/'.
half is offline   Reply With Quote
Old January 8, 2013, 02:17   #9
dixius99
Rookie
 
Join Date: Jan 2013
Posts: 5
dixius99 is on a distinguished road
Makes sense to me. If I could figure out how to disable Spaces, I'd be able to confirm...
dixius99 is offline   Reply With Quote
Old January 8, 2013, 02:40   #10
Derakon
Prophet
 
Derakon's Avatar
 
Join Date: Dec 2009
Posts: 9,005
Derakon is on a distinguished road
System Preferences -> Exposť & Spaces -> click on Spaces tab -> uncheck the "Enable Spaces" checkbox. Or change the "switch between spaces" keyboard controls.
Derakon is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
exclusion control for ego prefixes? saarn v4 5 May 15, 2012 10:44
After-the-fact control of breed explosions krugar Vanilla 12 September 16, 2010 19:48
Hellband: Control S hangs on Vector Linux konijn_ Variants 2 January 5, 2010 23:43
version control as save game system? devski Idle chatter 7 November 20, 2009 03:29
Isometric on a Mac st.patrik Variants 7 August 28, 2008 15:50


All times are GMT +1. The time now is 22:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.