Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old November 6, 2017, 20:02   #11
CivBesch
Apprentice
 
Join Date: Oct 2017
Posts: 93
CivBesch is on a distinguished road
I now inscribed with
@w0!;!.
but nothing happens.

this is the original comment in thangorodrim:

@w0^;^.
Use this as item 0 when weilding. Ask for confirmation before walking ( or running (.) with this item equipped. This is probably your shovel or pick. (The game attaches the command w0 to the 'X' key by default, so you can swap between your shovel and weapon by inscribing both with @w0.)
CivBesch is offline   Reply With Quote
Old November 7, 2017, 02:33   #12
kaypy
Swordsman
 
Join Date: May 2009
Posts: 261
kaypy is on a distinguished road
Dug through the code a bit. ! is only for actions where you select the item. ^ is used for checking any equipped item. The original version works when I test it.
kaypy is offline   Reply With Quote
Old November 7, 2017, 15:13   #13
CivBesch
Apprentice
 
Join Date: Oct 2017
Posts: 93
CivBesch is on a distinguished road
Which brings me back to my original questoon about how to produce the’^ Sign inang and
CivBesch is offline   Reply With Quote
Old November 7, 2017, 16:39   #14
kandrc
Swordsman
 
Join Date: Dec 2007
Posts: 264
kandrc is on a distinguished road
Quote:
Originally Posted by CivBesch View Post
Which brings me back to my original questoon about how to produce the’^ Sign inang and
Run Angband in curses mode, then cut-and-paste the symbol from here in the forums.
kandrc is offline   Reply With Quote
Old November 7, 2017, 16:41   #15
kaypy
Swordsman
 
Join Date: May 2009
Posts: 261
kaypy is on a distinguished road
Hmm. OK this is going to be "fun"

First you need to dump a copy of your keymaps from the =k menu

Find that (text) file, and edit it to add the following

Code:
keymap-act:\{0 @w0\^;\^.[Enter]
keymap-input:0:Z
This should be possible because you aren't in angband and have access to copypaste and stuff

Then, if you inscribe an object @{0, then the Z key will now cause @w0^;^. to be inscribed over it.

...

Or you could just be boring and use an onscreen keyboard or alt-094 or whatever.
kaypy is offline   Reply With Quote
Old November 7, 2017, 21:28   #16
luneya
Adept
 
Join Date: Aug 2015
Posts: 146
luneya is on a distinguished road
Quote:
Originally Posted by CivBesch View Post
I like these safety strokes. Thank you for the help.

Only I do not succeed in reproducing the '^' in angband. That is, working on MacBook with both French and US keyboards
Setting the keyboard to US and pressing SHIFT+6 doesn't succeed in producing a ^ symbol? WTF? That's always where that symbol has been on the US keyboard, and I can't imagine that the MacBook keyboard would be any different. I suppose you could try plugging in a standard USB keyboard and see if that helps.
luneya is offline   Reply With Quote
Old November 8, 2017, 11:51   #17
Werbaer
Apprentice
 
Join Date: Aug 2014
Posts: 83
Werbaer is on a distinguished road
Quote:
Originally Posted by CivBesch View Post
Which brings me back to my original questoon about how to produce the’^ Sign inang and
On a german keyboard, i need to type ^ followed by a space. Maybe that works for french, too?
Werbaer is offline   Reply With Quote
Old November 8, 2017, 12:59   #18
PowerWyrm
Veteran
 
PowerWyrm's Avatar
 
Join Date: Apr 2008
Posts: 2,065
PowerWyrm is on a distinguished road
Quote:
Originally Posted by Werbaer View Post
On a german keyboard, i need to type ^ followed by a space. Maybe that works for french, too?
Yes, it's the same in french.
__________________
PWMAngband variant maintainer - check http://www.mangband.org/forum/viewforum.php?f=9 to learn more about this new variant!
PowerWyrm is offline   Reply With Quote
Old November 8, 2017, 19:31   #19
CivBesch
Apprentice
 
Join Date: Oct 2017
Posts: 93
CivBesch is on a distinguished road
That is correct. The French, German and Belgian keyboards ^ is generated that way. Just like in the forum. But somehow in Angband it doesn't work. Also using the US keyboard doesn't work on Mac.

I have no idea how produce alt-094 on a mac keyboard as the 'alt'-key automatically produces a character every time you type a letter or figure.

I also saved the keycaps - which by the way is empty - and inserted the code:
keymap-act:\{0 @w0\^;\^.[Enter]
keymap-input:0:Z
After loading it and inscribing by shovel with @w0, saving it and typing 'Z', nothing happened.

I also tried the on-screen US, French and Belgian keyboards to no avail.

I find it annoying keeping you busy with this stuff, sorry for the bother.
CivBesch is offline   Reply With Quote
Old November 8, 2017, 22:41   #20
luneya
Adept
 
Join Date: Aug 2015
Posts: 146
luneya is on a distinguished road
This seems to explain why switching your software settings to US keyboard doesn't work properly:

https://apple.stackexchange.com/ques...eyboard-layout

Workarounds? Find a virtual keyboard program that does have the ^ symbol. Or buy a genuine US (ANSI) keyboard, and plug it into your macbook when playing Angband.
luneya is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Inscribing rod Altabin Vanilla 5 May 10, 2017 22:12
inscribing @0 and using 'x' to swap causes me to search intently Vanilla 2 May 31, 2014 00:48
[3.3.2] Game crashed upon inscribing. David Vestal Vanilla 0 December 27, 2011 02:52
Problem inscribing Gabrus Vanilla 3 February 9, 2011 11:26
FAangband Quiver Inscribing Whelk Variants 1 March 20, 2010 06:25


All times are GMT +1. The time now is 15:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.