Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old April 10, 2009, 12:13   #1
JoyrexJ9
Rookie
 
JoyrexJ9's Avatar
 
Join Date: Jun 2007
Location: London, UK
Posts: 11
JoyrexJ9 is on a distinguished road
Very strange fonts problem - Windows

Hi,

I've been playing V on/off for a long time, recently I fired it up after a long break from the game.

And my windows were blank!

I'm playing on Windows Vista and the problem seems to be down to the fonts.
If I select '8x13.fon' for the window (which is the default of course) nothing appears - all I get is a black screen, If I choose '8x13b.fon' it works! This happens randomly across the font sizes, for example '9X15.FON' = blank, but '9X15b.FON' & '10X17.FON' works fine.

I also experience the problem covered by this thread - http://angband.oook.cz/forum/showthread.php?t=1686
where occasionally Angband refuses to run, it appears in task manager "angband.exe" - but no window is visible

I can reproduce the problem on 3.0.9, 3.1.0-beta & the latest nightly build
This is very strange. I'm on the latest version of my graphics card driver. I've never had this problem before in all my years of playing Angband

Any thoughts?

Last edited by JoyrexJ9; April 10, 2009 at 12:32.
JoyrexJ9 is offline   Reply With Quote
Old April 10, 2009, 12:39   #2
PaulBlay
Knight
 
Join Date: Jan 2009
Posts: 657
PaulBlay is on a distinguished road
Quote:
Originally Posted by JoyrexJ9 View Post
Any thoughts?
Reboot. There's a good chance that will fix it.
__________________
Currently turning (Angband) Japanese.
PaulBlay is offline   Reply With Quote
Old April 10, 2009, 13:03   #3
JoyrexJ9
Rookie
 
JoyrexJ9's Avatar
 
Join Date: Jun 2007
Location: London, UK
Posts: 11
JoyrexJ9 is on a distinguished road
Well a reboot has fixed it, great!

There has to be some sort of bug here - related to the window not appearing bug, which is also fixed by a reboot.
JoyrexJ9 is offline   Reply With Quote
Old April 10, 2009, 13:18   #4
PaulBlay
Knight
 
Join Date: Jan 2009
Posts: 657
PaulBlay is on a distinguished road
Quote:
Originally Posted by JoyrexJ9 View Post
There has to be some sort of bug here - related to the window not appearing bug, which is also fixed by a reboot.
I think it's an issue relating to the way Windows handles fonts. IIRC some variant moved to .bmp files instead of .fon files for character display for just that reason.
__________________
Currently turning (Angband) Japanese.
PaulBlay is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3.1.1 strange crash bebo Vanilla 1 February 9, 2009 00:49
[O] and [FA] fonts on Nintendo DS fearoffours Variants 3 January 30, 2009 08:09
Massacred at lvl 15 by strange demon Wartom Pendragon Vanilla 9 August 1, 2008 12:38
[Un] Changing Fonts to be like V fonts? Poop Loops Variants 6 May 16, 2008 03:00
Strange Isolated Room z118 AAR 1 February 5, 2008 00:38


All times are GMT +1. The time now is 13:09.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.