Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old March 25, 2008, 21:09   #1
ditoLoco
Rookie
 
Join Date: Mar 2008
Posts: 1
ditoLoco is on a distinguished road
graphic problems Windows XP Angband

I have downloaded angband-3.0.9b version and tried to play it.
Unfortunately, the graphic options are unavailable (they are in gray color and i cannot turn them
on). I have downloaded a version with tiles, and i also downloaded, just in case, manually 32x32
tiles. Still - no change. Whatever i do - changing the config etc. the graphic option is still
unavailable (to be precise - graphics from top menu is available, but all the
choices "None", "Old Tiles", "Adam Bolt's tiles", etc. are gray and unavailable). i even succeeded to checked them through config but they remain gray and i see no graphic (only ASCII) Can someone
help me with this?

bartek
ditoLoco is offline   Reply With Quote
Old March 26, 2008, 00:26   #2
Anne
Adept
 
Join Date: Feb 2008
Posts: 134
Anne is on a distinguished road
I've noticed myself that the graphics options will be grayed out if there's a message onscreen that I have to respond to, even if it's to hit escape to get out of it. Could that be the problem?
Anne is offline   Reply With Quote
Old May 8, 2009, 00:09   #3
hapax
Rookie
 
Join Date: May 2009
Posts: 2
hapax is on a distinguished road
Hey there,

Sorry to resurrect a year-old thread, but I'm having this same problem and can't find any other references to it on the whole wide Internets.

I'm on Vista, have downloaded all the graphics files and put them in the right directory (in fact, I copied them into a bunch of directories to see if that would help Angband find them), messed around with .ini in a variety of ways...

... no matter what I do, the graphics options are always completely greyed out. I can only play the game in raw ASCII. Even that I wouldn't mind so much, but the tile size is TINY and I can't change it. It doesn't seem to have anything to do with open windows as Anne suggested.

Can anyone help?
hapax is offline   Reply With Quote
Old May 8, 2009, 02:38   #4
buzzkill
Prophet
 
buzzkill's Avatar
 
Join Date: May 2008
Location: Indiana, USA
Posts: 2,939
Donated: $8
buzzkill is on a distinguished road
Quote:
Originally Posted by hapax View Post
Can anyone help?
Assuming Vanilla and DVG 32x32 tiles.
The files need to be named 32x32.bmp and mask32.bmp and must be in bitmap format (not .png .jpg or .zip - don't just rename the extension, convert the file).
The files need to be located in the angband/lib/xtra/graf directory.
I don't know if it will make a difference or not, but are you logged on as an administrator? If not try it as an admin.
...and if all else fails... reboot.

I am able to play on Vista with tiles, without a problem.
__________________
www.mediafire.com/buzzkill - Get your 32x32 tiles here. UT32 now compatible Ironband and Quickband 9/6/2012.
My banding life on Buzzkill's ladder.
buzzkill is offline   Reply With Quote
Old May 8, 2009, 03:38   #5
Donald Jonker
Knight
 
Join Date: Jun 2008
Posts: 593
Donald Jonker is on a distinguished road
Also make sure the directory that your game isn't inside another directory called "angband" ...this has thrown it off for me. So don't have it called C:\angband\angband\angband.exe

To be extra sure just put it in C:\angband

Has produced problems for me displaying tiles in variants but not vanilla, but who knows - you might get lucky.
__________________
Bands, / Those funny little plans / That never work quite right.
-Mercury Rev
Donald Jonker is offline   Reply With Quote
Old May 8, 2009, 07:33   #6
hapax
Rookie
 
Join Date: May 2009
Posts: 2
hapax is on a distinguished road
A-ha! Donald seems to have figured it out: the zip file created a superfluous "Angband" directory under the game directory I made. I have my tiles now. Thanks for your help!
hapax is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Unangband/Angband from SVN and Compiling on Windows andrewdoull Development 133 April 7, 2011 15:28
Problems running Angband ChodTheWacko Vanilla 12 January 12, 2011 08:43
Angband Borg 3.0.9 and windows Zappa Vanilla 38 October 27, 2010 21:31
Problems angband winxp smokie007 Vanilla 24 November 12, 2007 11:42
problems with 'breeding' monsters Halloween Jack Vanilla 12 November 5, 2007 12:44


All times are GMT +1. The time now is 11:15.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.