Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Variants

Reply
 
Thread Tools Display Modes
Old July 6, 2019, 15:30   #1
hernaldog
Rookie
 
hernaldog's Avatar
 
Join Date: Apr 2014
Location: Santiago, Chile
Posts: 21
hernaldog is on a distinguished road
FAangband compilation error unrecognized command line option '-mno-cygwin'

Hi guys,
I return with my personal project: the translation of FAangband versión 1.4.4 to Spanish. I'm i 60% of text translation. But I need compile the source.

The source that I using are from 24-05-2016.

I use Windows 10.

I download Cygwin x64 and MinGW, both last version, but I get the next error:

Using MinGW:

HTML Code:
mingw32-make -f Makefile.win
gcc -DWINDOWS -static -Iwin/include -Lwin/lib -Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -std=c99 -Wdeclaration-after-statement -O2 -I. -mno-cygwin -c -o identify.o identify.c
gcc: error: unrecognized command line option '-mno-cygwin'; did you mean '-mno-clwb'?
Makefile.win:127: recipe for target 'identify.o' failed
mingw32-make: *** [identify.o] Error 1
Using Cygwin:

HTML Code:
make -f Makefile.win
gcc -DWINDOWS -static -Iwin/include -Lwin/lib -Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -std=c99 -Wdeclaration-after-statement -O2 -I. -mno-cygwin -c -o identify.o identify.c
gcc: error: unrecognized command line option '-mno-cygwin'; did you mean '-mno-clwb'?
Makefile.win:127: recipe for target 'identify.o' failed
mingw32-make: *** [identify.o] Error 1
Any help?
__________________
La web de Dark-N - Traducciones de Juegos
http://darkn.romhackhispano.org/
hernaldog is offline   Reply With Quote
Old July 6, 2019, 17:03   #2
Pete Mack
Prophet
 
Join Date: Apr 2007
Location: Seattle, WA
Posts: 5,325
Donated: $40
Pete Mack is on a distinguished road
try
MINGW=YES mingw32-make -f makefile.win
This works for Vanilla. I don't know if it will work for FA, which is a fairly old distro apparently depending on an older version of gcc.
Pete Mack is offline   Reply With Quote
Old July 6, 2019, 23:49   #3
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 54
Posts: 7,733
Donated: $60
Nick is on a distinguished road
I can confirm that Pete's command line works for me; that's Windows 10, msys (version 1.0, I think?) and mingw. gcc version is 4.6.2.
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is offline   Reply With Quote
Old July 7, 2019, 04:30   #4
hernaldog
Rookie
 
hernaldog's Avatar
 
Join Date: Apr 2014
Location: Santiago, Chile
Posts: 21
hernaldog is on a distinguished road
Quote:
Originally Posted by Pete Mack View Post
try
MINGW=YES mingw32-make -f makefile.win
This works for Vanilla. I don't know if it will work for FA, which is a fairly old distro apparently depending on an older version of gcc.

Hi Pete, thanks for your response.
Now I get the error:

HTML Code:
src>MINGW=YES mingw32-make -f makefile.win
"MINGW" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.

In english: it is not recognized as an internal or external command,
program or batch file executable.

Maybe, I miss some environment variable?

I have in the Path variable, C:\MinGW\bin

How can I know my version of gcc?

regards!
__________________
La web de Dark-N - Traducciones de Juegos
http://darkn.romhackhispano.org/
hernaldog is offline   Reply With Quote
Old July 7, 2019, 05:47   #5
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 54
Posts: 7,733
Donated: $60
Nick is on a distinguished road
The point of the
Code:
MINGW=yes
part of the command is to set the environment variable MINGW to yes, so you could do that separately, probably by
Code:
export MINGW="yes"
To get your version of gcc,
Code:
gcc --version
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is offline   Reply With Quote
Old July 7, 2019, 17:55   #6
hernaldog
Rookie
 
hernaldog's Avatar
 
Join Date: Apr 2014
Location: Santiago, Chile
Posts: 21
hernaldog is on a distinguished road
Quote:
Originally Posted by Nick View Post
The point of the
Code:
MINGW=yes
part of the command is to set the environment variable MINGW to yes, so you could do that separately, probably by
Code:
export MINGW="yes"
To get your version of gcc,
Code:
gcc --version
Hi Nick

I add manually by Windows Preferences the environment variable, and this compiled ok.

The command I used was:

HTML Code:
mingw32-make -f Makefile.win

Thanks!
__________________
La web de Dark-N - Traducciones de Juegos
http://darkn.romhackhispano.org/
hernaldog is offline   Reply With Quote
Reply

Tags
faangband


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Parse error in randart line epatton Vanilla 1 October 30, 2017 18:06
FAangband - Compilation problem, need help. arsen12 Development 1 February 6, 2016 04:34
"Error at line 1988 of 'artifact.txt'. Record 136 contains a many entries' error. thedude Vanilla 1 December 12, 2014 04:31
command line for loading an existing character Bilbo Vanilla 4 June 24, 2010 17:27
cygwin 1.7 compile error david3x3x3 Development 0 September 13, 2009 00:03


All times are GMT +1. The time now is 17:36.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.