Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old June 20, 2011, 16:04   #1
Zambaku
Apprentice
 
Join Date: Dec 2007
Posts: 80
Zambaku is on a distinguished road
Enable sound?

I'm a bit confused about Angband 3.2, it has a folder for sound, but I can't seem to turn it on. Could anyone guide me through the process of enabling sound?^^'
Zambaku is offline   Reply With Quote
Old June 20, 2011, 16:40   #2
Therem Harth
Knight
 
Join Date: Jan 2008
Posts: 926
Therem Harth is on a distinguished road
You have to run ./configure with --enable-sdl and --enable-sdl-mixer (sound only works in SDL mode IIRC). Then you have to start the game and enable it in your options settings.

Be warned, sound in V is rather loud!
Therem Harth is offline   Reply With Quote
Old June 20, 2011, 17:52   #3
Zambaku
Apprentice
 
Join Date: Dec 2007
Posts: 80
Zambaku is on a distinguished road
Uhm, how do I run ./configure? >_>
Zambaku is offline   Reply With Quote
Old June 20, 2011, 18:52   #4
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,060
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Quote:
Originally Posted by Zambaku View Post
I'm a bit confused about Angband 3.2, it has a folder for sound, but I can't seem to turn it on. Could anyone guide me through the process of enabling sound?^^'
What is your platform? How are you starting Angband? If you're double-clicking an icon in Windows, someone will be able to help, I'm sure.
__________________
"3.4 is much better than 3.1, 3.2 or 3.3. It still is easier than 3.0.9, but it is more convenient to play without being ridiculously easy, so it is my new favorite of the versions." - Timo Pietila
Magnate is offline   Reply With Quote
Old June 20, 2011, 19:36   #5
Zambaku
Apprentice
 
Join Date: Dec 2007
Posts: 80
Zambaku is on a distinguished road
Windows XP, and yes, I double click the exe too start
Zambaku is offline   Reply With Quote
Old June 20, 2011, 19:44   #6
Magnate
Angband Devteam member
 
Join Date: May 2007
Location: London, UK
Posts: 5,060
Magnate is on a distinguished road
Send a message via MSN to Magnate Send a message via Yahoo to Magnate
Quote:
Originally Posted by Zambaku View Post
Windows XP, and yes, I double click the exe too start
Well, I don't use Windows, but plenty of people do, so I'm sure someone will be along to help.

Just to check: sound works fine for all your other games, right?
__________________
"3.4 is much better than 3.1, 3.2 or 3.3. It still is easier than 3.0.9, but it is more convenient to play without being ridiculously easy, so it is my new favorite of the versions." - Timo Pietila
Magnate is offline   Reply With Quote
Old June 20, 2011, 20:01   #7
Zambaku
Apprentice
 
Join Date: Dec 2007
Posts: 80
Zambaku is on a distinguished road
Yes, my sound works perfectly, so that's not the problem^^
Zambaku is offline   Reply With Quote
Old June 20, 2011, 20:35   #8
Timo Pietilš
Prophet
 
Join Date: Apr 2007
Location: Climbing up from hole I just dug.
Posts: 4,096
Timo Pietilš is on a distinguished road
Quote:
Originally Posted by Zambaku View Post
I'm a bit confused about Angband 3.2, it has a folder for sound, but I can't seem to turn it on. Could anyone guide me through the process of enabling sound?^^'
Go to options menu "=", there under "Interface and display options" is setting "use sound". Turn that on. Sounds should be playing now.
Timo Pietilš is offline   Reply With Quote
Old June 21, 2011, 02:52   #9
bdo
Rookie
 
Join Date: Apr 2008
Posts: 11
bdo is on a distinguished road
Quote:
Originally Posted by Therem Harth View Post
You have to run ./configure with --enable-sdl and --enable-sdl-mixer (sound only works in SDL mode IIRC).
FWIW, it shouldn't be necessary to compile with both --enable-sdl and --enable-sdl-mixer to get sound on linux. My original patch which added --enable-sdl-mixer was to allow sound support on linux with the curses & x11 interfaces using the now-defunct -v command option. That pre-dated the SDL ui (of course, something could have changed in the meantime, but I haven't checked in a while)

cheers,

- b.
bdo is offline   Reply With Quote
Old June 21, 2011, 07:24   #10
Zambaku
Apprentice
 
Join Date: Dec 2007
Posts: 80
Zambaku is on a distinguished road
Awesome, I finaly have sound! Thanks for all the help, guys. Especially Timo Pietilš for tipping on pressing the "=" key to bring up the options =D


Edit:
Hm, I can't seem to get the ambient sound to work correctly, when I enter the town or a dungeon floor, the ambient sound plays as it should, but when I kill an enemy for example and another sound is played, the ambient sound stops completely, or starts from the beginning. Any way of having it play continuely?

Last edited by Zambaku; June 21, 2011 at 15:38.
Zambaku is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound issue CJNyfalt Vanilla 8 June 15, 2011 07:32
Enable weapon damage details? ScottG Vanilla 2 July 6, 2010 17:32
Sound Not working at all froboz Vanilla 1 June 22, 2010 18:12
SDL sound Nick Development 1 July 16, 2009 21:14
Sound configuration nurak Vanilla 6 May 14, 2008 10:23


All times are GMT +1. The time now is 13:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.