Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Development

Reply
 
Thread Tools Display Modes
Old May 25, 2009, 21:29   #51
will_asher
DaJAngband Maintainer
 
will_asher's Avatar
 
Join Date: Apr 2007
Location: San Antonio, TX
Posts: 927
Donated: $10
will_asher is on a distinguished road
So I was about to send DJA1098 to pav to post on oook, but I copied DaJAngband to my other computer and it wouldn't run. It gave me a message that said, "The application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."
anyone know what this means?
__________________
Will_Asher

Play DaJAngband:
http://sites.google.com/site/dajangbandwebsite/home
will_asher is offline   Reply With Quote
Old May 25, 2009, 21:31   #52
PaulBlay
Knight
 
Join Date: Jan 2009
Posts: 657
PaulBlay is on a distinguished road
Quote:
Originally Posted by will_asher View Post
It gave me a message that said, "The application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."
anyone know what this means?
I think that means it's a "Debug" compile not a "Release" compile.

See here for how to do a release compile.

(You just need to notice the "Set 'configuration' to "Release"." and optionally "Type "/DWINDOWS /DNDEBUG" into the Command line. " bits)
__________________
Currently turning (Angband) Japanese.
PaulBlay is offline   Reply With Quote
Old May 25, 2009, 21:34   #53
Pete Mack
Prophet
 
Join Date: Apr 2007
Location: Seattle, WA
Posts: 5,273
Donated: $40
Pete Mack is on a distinguished road
It probably means you compiled in /Debug mode, but you don't have the Debug system libraries installed on your other machine. VC expects you to distribute only /Release builds.
Pete Mack is offline   Reply With Quote
Old May 25, 2009, 22:12   #54
will_asher
DaJAngband Maintainer
 
will_asher's Avatar
 
Join Date: Apr 2007
Location: San Antonio, TX
Posts: 927
Donated: $10
will_asher is on a distinguished road
..oops, okay thanks
__________________
Will_Asher

Play DaJAngband:
http://sites.google.com/site/dajangbandwebsite/home

Last edited by will_asher; May 25, 2009 at 22:40.
will_asher is offline   Reply With Quote
Old May 25, 2009, 22:40   #55
will_asher
DaJAngband Maintainer
 
will_asher's Avatar
 
Join Date: Apr 2007
Location: San Antonio, TX
Posts: 927
Donated: $10
will_asher is on a distinguished road
I set configuration to release, but it still gives me the same error when I copy it to my other computer.

EDIT: nevermind, I just re-compiled with my old compiler. I guess it's still good for something.

unrelated PS: the rephial wiki isn't working
__________________
Will_Asher

Play DaJAngband:
http://sites.google.com/site/dajangbandwebsite/home

Last edited by will_asher; May 25, 2009 at 23:25.
will_asher is offline   Reply With Quote
Old May 25, 2009, 23:53   #56
Pete Mack
Prophet
 
Join Date: Apr 2007
Location: Seattle, WA
Posts: 5,273
Donated: $40
Pete Mack is on a distinguished road
You are absolutely sure you copied the right executable? (The one from src/Release--the other ones may or may not be correct.) Also, what exactly does it say for the linker options? (Does it say winmm.lib, or winmm.dll, etc?)
Pete Mack is offline   Reply With Quote
Old May 26, 2009, 00:16   #57
will_asher
DaJAngband Maintainer
 
will_asher's Avatar
 
Join Date: Apr 2007
Location: San Antonio, TX
Posts: 927
Donated: $10
will_asher is on a distinguished road
Just a minute ago I found a copy of my DaJAngband debug folder in my "My Documents" folder. I guess for some reason Visual C++ must've created a copy there and was putting the new executible in a completely unexpected place. That's probably what was wrong.
(It does say winmm.lib in the linker options).
__________________
Will_Asher

Play DaJAngband:
http://sites.google.com/site/dajangbandwebsite/home
will_asher is offline   Reply With Quote
Old January 22, 2011, 03:23   #58
will_asher
DaJAngband Maintainer
 
will_asher's Avatar
 
Join Date: Apr 2007
Location: San Antonio, TX
Posts: 927
Donated: $10
will_asher is on a distinguished road
<serious thread necromancy>

I finally got VC++ to install on this computer. yay.

I am reusing this thread because I'm using Paul Blay's instructions on page 2 of this thread for compiling in VC++ (and I'm also trying to fix a crash bug again)

When compiling the game (after getting rid of my errors in the code which didn't comply with VC++ standards), I'm getting these errors which I don't know what they mean, any help?

fatal error CVT1100: duplicate resource. type:MENU, name:ANGBAND, language:0x0409 CVTRES

fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt DaJAngband130
__________________
Will_Asher

Play DaJAngband:
http://sites.google.com/site/dajangbandwebsite/home
will_asher is offline   Reply With Quote
Old January 22, 2011, 03:58   #59
Pete Mack
Prophet
 
Join Date: Apr 2007
Location: Seattle, WA
Posts: 5,273
Donated: $40
Pete Mack is on a distinguished road
Bing, like google, is your friend:
http://msdn.microsoft.com/en-us/libr...6z(VS.71).aspx

Not sure about the COFF failure, but one thing at a time.
Pete Mack is offline   Reply With Quote
Old January 22, 2011, 06:26   #60
will_asher
DaJAngband Maintainer
 
will_asher's Avatar
 
Join Date: Apr 2007
Location: San Antonio, TX
Posts: 927
Donated: $10
will_asher is on a distinguished road
Okay got it to build. I had included the .rc file which was created by DevC++, so I had two .rc files and that apparently messed things up.

PS: This is weird. I found a bug that happens when compiling with VC++, but completely dissapears if I compile with DEVC++
__________________
Will_Asher

Play DaJAngband:
http://sites.google.com/site/dajangbandwebsite/home

Last edited by will_asher; January 23, 2011 at 03:46.
will_asher is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[FA] Crash Bug Zikke Variants 8 February 19, 2009 04:20
r1264 bug: crash at prompt (Windows) Colbey Vanilla 11 February 13, 2009 16:39
Entro crash Zikke Variants 2 February 2, 2009 20:08
Elemental attacks destroying inventory items - challenging or frustrating? hugorune Vanilla 24 January 28, 2009 08:23
YASD - the most frustrating death in the world Big Al AAR 13 February 2, 2008 18:31


All times are GMT +1. The time now is 10:23.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.