Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old July 20, 2010, 14:02   #1
saw
Scout
 
saw's Avatar
 
Join Date: May 2010
Location: Huntington NY
Age: 53
Posts: 27
saw is on a distinguished road
Question Excessive Processor Use for a text-interface?

I dunno... I used to play Moria on a Vax-11/780 back in 1986 along with 20 other people, and response time was great, so it surprises me to see all four of my AMD Phenom 9500 processors spike up to 60% usage, and my case fans power-up to disperse the generated heat whenever Angband is running...

The processors spike, and remain spiked, as long as the Angband is running. As soon as I close the window, processor usage returns to normal.

Angband itself, as a process, appears to be sleeping, and using only 4% of CPU, but wnk-applet spikes 68-75%+ constantly, and metacity as well, between 16 and 20%. They alternate between Running and Sleeping.

Is this normal??? I can't imagine this much horsepower would be needed.

Ubuntu 10.04 Lucid (but the problem has been seen from the very first time I loaded Angband back at Ubuntu 7.0)

Angband version is now 3.0.8 (but the problem has been seen across all releases I've ever loaded)

Thoughts? Suggestions? Solutions? Or is this "just the way it is"?
saw is offline   Reply With Quote
Old July 20, 2010, 14:34   #2
d_m
Angband Devteam member
 
d_m's Avatar
 
Join Date: Aug 2008
Location: Philadelphia, PA, USA
Age: 39
Posts: 1,516
d_m is on a distinguished road
Quote:
Originally Posted by saw View Post
Angband itself, as a process, appears to be sleeping, and using only 4% of CPU, but wnk-applet spikes 68-75%+ constantly, and metacity as well, between 16 and 20%. They alternate between Running and Sleeping.

Is this normal??? I can't imagine this much horsepower would be needed.

Ubuntu 10.04 Lucid (but the problem has been seen from the very first time I loaded Angband back at Ubuntu 7.0)

Angband version is now 3.0.8 (but the problem has been seen across all releases I've ever loaded)

Thoughts? Suggestions? Solutions? Or is this "just the way it is"?
3.0.8 is really old. Do you see this with one of the newer releases (3.1.2 or a nightly build)? Also, are you playing in a terminal, or via X11 or SDL or what? If you are using the GTK display mode that is known to be old, crufty, buggy and probably inefficient. If you run "angband -mgcu" I would be surprised if you saw this.
__________________
linux->xterm->screen->pmacs
d_m is offline   Reply With Quote
Old July 20, 2010, 14:37   #3
SaThaRiel
Adept
 
SaThaRiel's Avatar
 
Join Date: Nov 2009
Posts: 173
SaThaRiel is on a distinguished road
Ubuntu Lucid should have 1:3.1.1.1626-1 as version.

As d_m suggested, try a newer version or maybe the nightlies. Theyre not available directly but can be compiled without much problems.

P.S. Can't see the behaviour with Lucid. Maybe you have a strange issue with you graphics driver? When its not installed correctly it uses the CPU instead of GPU to calculate - which is a bad idea today.
__________________
Proud candidate for the Angband Darwin Award!
SaThaRiel is offline   Reply With Quote
Old July 20, 2010, 14:43   #4
saw
Scout
 
saw's Avatar
 
Join Date: May 2010
Location: Huntington NY
Age: 53
Posts: 27
saw is on a distinguished road
Quote:
Originally Posted by d_m View Post
3.0.8 is really old. Do you see this with one of the newer releases (3.1.2 or a nightly build)? Also, are you playing in a terminal, or via X11 or SDL or what? If you are using the GTK display mode that is known to be old, crufty, buggy and probably inefficient. If you run "angband -mgcu" I would be surprised if you saw this.
3.08 is what's available in the Ubuntu package. I tried loading it differently once, and managed to trash my OS build, so I'm sticking to what's already packaged.

I ran it from a terminal window, using -mgcu as you suggested and didn't see a processor problem, so it's in the interface somewhere.

I'm running it in a Gnome window, and the reason I prefer that versus a terminal window, is that I can see almost the entire dungeon level in my widescreen, which is SO much more pleasant than the constant scrolling.

That said - is there anything I can do to reduce the processor hogging and still get the widescreen view?

Also - I'm still learning when it comes to Linux, so apologies if my terminology isn't quite right - I'm a mainframer by trade
saw is offline   Reply With Quote
Old July 20, 2010, 14:46   #5
saw
Scout
 
saw's Avatar
 
Join Date: May 2010
Location: Huntington NY
Age: 53
Posts: 27
saw is on a distinguished road
Quote:
Originally Posted by SaThaRiel View Post
Ubuntu Lucid should have 1:3.1.1.1626-1 as version.

As d_m suggested, try a newer version or maybe the nightlies. Theyre not available directly but can be compiled without much problems.

P.S. Can't see the behaviour with Lucid. Maybe you have a strange issue with you graphics driver? When its not installed correctly it uses the CPU instead of GPU to calculate - which is a bad idea today.
1.3.1.1 is the version - silly me, I grabbed it from the helptext

The graphics driver is the most recent NVIDIA, and appears to be working properly. Any suggestions on settings for it?
saw is offline   Reply With Quote
Old July 20, 2010, 18:16   #6
SaThaRiel
Adept
 
SaThaRiel's Avatar
 
Join Date: Nov 2009
Posts: 173
SaThaRiel is on a distinguished road
I think if your gpu driver wont work correctly you should recognize the high load somewhere else too - was just a guess
To debug the problem it maybe a good start if you launch angband from a terminal and redirect stdout and stderror to a file which you can post here
Code:
angband > angband_errors.txt 2>&1
Maybe there is something unusual (lots of wrong library calls). You just need to play some steps and then finish your game again, the file might grow too large otherwise.

Also check if the angband you are using is really the angband from Ubuntu
Code:
which angband
ls -l $(which angband)
Maybe there is something left from your previous selfcompile installation.

P.S. Basically i think that the main problem is that youre playing angband with a "resolution" of something like 600 rowsx100 cols. You should also post the window settings here. Can't test at the moment but maybe tomorrow.
__________________
Proud candidate for the Angband Darwin Award!

Last edited by SaThaRiel; July 20, 2010 at 18:26.
SaThaRiel is offline   Reply With Quote
Old July 21, 2010, 02:57   #7
chris
PosChengband Maintainer
 
Join Date: Jan 2008
Posts: 702
chris is on a distinguished road
Quote:
Originally Posted by saw View Post
I'm running it in a Gnome window, and the reason I prefer that versus a terminal window, is that I can see almost the entire dungeon level in my widescreen, which is SO much more pleasant than the constant scrolling.
I don't know if this is the same issue, but my CPU spikes when I maximize the terminal window under Ubuntu. But if the window is just large, and not quite maximized, CPU usage falls to near 0. You might want to try it out ...

--Chris
chris is offline   Reply With Quote
Old July 21, 2010, 06:59   #8
SaThaRiel
Adept
 
SaThaRiel's Avatar
 
Join Date: Nov 2009
Posts: 173
SaThaRiel is on a distinguished road
Hm, i can maximize the window in X11 (option -mx11) and the cpu load is just a little bit higher. But i am using the latest SVN version. Also i dont see any errors in my term window which is a good sign

I may try the Ubuntu version later - also i don't have a really big screen.
__________________
Proud candidate for the Angband Darwin Award!
SaThaRiel is offline   Reply With Quote
Old July 21, 2010, 15:47   #9
chris
PosChengband Maintainer
 
Join Date: Jan 2008
Posts: 702
chris is on a distinguished road
Quote:
Originally Posted by chris View Post
I don't know if this is the same issue, but my CPU spikes when I maximize the terminal window under Ubuntu. But if the window is just large, and not quite maximized, CPU usage falls to near 0. You might want to try it out ...

--Chris
I just installed 3.0.9 which is the only version of Angband available thru Synaptic Package Manager. When I maximize, both cores utilize 60% cpu each. When I "Unmaximize" the window, I can make it as large as I like, and both cores utilize about 3% cpu. I generally run Hengband rather than Angband, but I would guess that the Terminal handling code is the same between them. I am not running 10.04 of Ubuntu, but the version before that, although I can't figure out how to tell what version I am running.

I suspect this is an issue with terminal windows and Gnome, but I know precisely 0 about developing under linux. My monitor is 1680x1050.

It is odd that just maximizing a window would generate so much heat ... Good in Winter but bad in Summer
chris is offline   Reply With Quote
Old July 21, 2010, 15:53   #10
chris
PosChengband Maintainer
 
Join Date: Jan 2008
Posts: 702
chris is on a distinguished road
Quote:
Originally Posted by chris View Post
I just installed 3.0.9 which is the only version of Angband available thru Synaptic Package Manager. When I maximize, both cores utilize 60% cpu each. When I "Unmaximize" the window, I can make it as large as I like, and both cores utilize about 3% cpu. I generally run Hengband rather than Angband, but I would guess that the Terminal handling code is the same between them. I am not running 10.04 of Ubuntu, but the version before that, although I can't figure out how to tell what version I am running.

I suspect this is an issue with terminal windows and Gnome, but I know precisely 0 about developing under linux. My monitor is 1680x1050.

It is odd that just maximizing a window would generate so much heat ... Good in Winter but bad in Summer
Noise noise noise ...

>angband -mgcu
Does not reproduce the problem
>angband
Reproduces the problem
>angband -mx11
Reproduces the problem
chris is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
excessive store prices PowerDiver Vanilla 19 June 20, 2010 21:22
Request: Change text on enchantment fizzix Vanilla 7 May 5, 2010 07:52
Excessive amounts of gold? Sean Vanilla 3 March 19, 2009 16:44
Export entire message log to text file PaulBlay Vanilla 2 February 28, 2009 19:24
Interface trouble ofosho Vanilla 0 January 21, 2009 03:19


All times are GMT +1. The time now is 23:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.