Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old July 6, 2007, 08:45   #1
mjtokarski
Rookie
 
Join Date: Jul 2007
Posts: 4
mjtokarski is on a distinguished road
problem with graphics

When I try to load the David Gervais tileset, I get the following error messages:

Cannot read bitmap file '32x32.bmp'

Cannot initialize graphics

Anyone got any ideas as to what's going on? It used to work until a few days ago and I haven't changed anything on the computer.

cheers
Michael
mjtokarski is offline   Reply With Quote
Old July 6, 2007, 14:38   #2
JoyrexJ9
Rookie
 
JoyrexJ9's Avatar
 
Join Date: Jun 2007
Location: London, UK
Posts: 11
JoyrexJ9 is on a distinguished road
You need to download the tileset (for some reason, it's not included in the main distribution). Download the file graf-32x32-306.zip from here http://angband.oook.cz/download.php

Unzip it into the lib\xtra\graf directory (it should contain two files 32x32.bmp and mask32.bmp)

That should fix it.
JoyrexJ9 is offline   Reply With Quote
Old July 6, 2007, 23:35   #3
mjtokarski
Rookie
 
Join Date: Jul 2007
Posts: 4
mjtokarski is on a distinguished road
I've already got the tileset. Like I said, it used to work fine but now it won't load.
mjtokarski is offline   Reply With Quote
Old July 7, 2007, 05:16   #4
Bill Peterson
Apprentice
 
Join Date: Jul 2007
Location: Flyover country
Posts: 82
Bill Peterson is on a distinguished road
Send a message via AIM to Bill Peterson
Quote:
Originally Posted by mjtokarski View Post
and I haven't changed anything on the computer.
Is this completely true, you haven't changed ANYTHING? If so, you might try replacing the file - it may have been corrupted. If this doesn't work try giving us some more information like OS, Angband version, etc.

Bill
Bill Peterson is offline   Reply With Quote
Old July 7, 2007, 05:41   #5
mjtokarski
Rookie
 
Join Date: Jul 2007
Posts: 4
mjtokarski is on a distinguished road
Yep, completely true, I'm afraid.

I tried replacing the files - no good.

I'm using the pr2 version of angband in windows xp sp2 but I have the same problem when I go back to the 3.06 version.

I've played around a bit this morning:

I have my desktop set to 32 bit display andthe tileset won't load.

If I change to 16 bit, then run angband and load the tileset, it works fine - even if I change back to 32 bit while angband is running. But, when I try to run agband with the tileset again in 32 bit screen, it won't work.

Last edited by mjtokarski; July 7, 2007 at 07:23.
mjtokarski is offline   Reply With Quote
Old July 7, 2007, 14:19   #6
takkaria
Veteran
 
takkaria's Avatar
 
Join Date: Apr 2007
Posts: 1,858
Donated: $40
takkaria is on a distinguished road
Quote:
Originally Posted by mjtokarski View Post
If I change to 16 bit, then run angband and load the tileset, it works fine - even if I change back to 32 bit while angband is running. But, when I try to run agband with the tileset again in 32 bit screen, it won't work.
I can't reproduce this, and I have no idea why this is happening for you; the code suggests that the game is just having a problem loading the graphics file.
takkaria is offline   Reply With Quote
Old July 7, 2007, 16:52   #7
Bill Peterson
Apprentice
 
Join Date: Jul 2007
Location: Flyover country
Posts: 82
Bill Peterson is on a distinguished road
Send a message via AIM to Bill Peterson
I can't confirm his problem under Windows as I'm running Linux. Perhaps I can try later today. But I can reproduce a similar problem using my build under Ubuntu.

From the comamnd line:

./angband -g gives me Adam Bolt graphics
./angband -g -- -b gives me Adam Bolt graphics w/bigtile
./angband -g -- -b -o gives me original graphics w/bigtile
./angband -g -- -b -g gives me no graphics at all, the same as just ./angband

All the above commands work as expected using the pr1 build, so the problem does seem to be with pr2 and Gervais graphics.

Bill
Bill Peterson is offline   Reply With Quote
Old July 7, 2007, 17:17   #8
takkaria
Veteran
 
takkaria's Avatar
 
Join Date: Apr 2007
Posts: 1,858
Donated: $40
takkaria is on a distinguished road
Quote:
Originally Posted by Bill Peterson View Post
I can't confirm his problem under Windows as I'm running Linux. Perhaps I can try later today. But I can reproduce a similar problem using my build under Ubuntu.

From the comamnd line:

./angband -g gives me Adam Bolt graphics
./angband -g -- -b gives me Adam Bolt graphics w/bigtile
./angband -g -- -b -o gives me original graphics w/bigtile
./angband -g -- -b -g gives me no graphics at all, the same as just ./angband

All the above commands work as expected using the pr1 build, so the problem does seem to be with pr2 and Gervais graphics.
That's because you haven't downloaded the Gervais graphics.

Try putting the files in http://angband.oook.cz/download/extr...-32x32-306.zip in your lib/xtra folder.
takkaria is offline   Reply With Quote
Old July 7, 2007, 20:31   #9
Bill Peterson
Apprentice
 
Join Date: Jul 2007
Location: Flyover country
Posts: 82
Bill Peterson is on a distinguished road
Send a message via AIM to Bill Peterson
I wish it could be so simple. If I've made an error, it's more subtle than that.

wfp@wfp-desktop:~/angband-3.0.8pr2/lib/xtra/graf$ ls -la
total 6061
drwxr-xr-x 2 wfp wfp 360 2007-07-05 12:52 .
drwxr-xr-x 5 wfp wfp 176 2007-07-04 20:33 ..
-rw-r--r-- 1 wfp wfp 492598 2007-03-23 16:03 16x16.bmp
-rw-r--r-- 1 wfp wfp 166508 2007-05-07 11:59 16x16.png
-rw-r--r-- 1 wfp wfp 3933240 2004-11-17 18:13 32x32.bmp
-rw-r--r-- 1 wfp wfp 469484 2007-05-07 11:59 32x32.png
-rw-r--r-- 1 wfp wfp 103286 2007-03-23 16:03 8x13.bmp
-rw-r--r-- 1 wfp wfp 203830 2007-03-23 16:03 8x8.bmp
-rw-r--r-- 1 wfp wfp 45099 2007-03-23 16:03 8x8.png
-rw-r--r-- 1 wfp wfp 200758 2007-03-23 16:03 backgrnd.bmp
-rw-r--r-- 1 wfp wfp 423 2007-06-06 17:04 Makefile
-rw-r--r-- 1 wfp wfp 491584 2004-11-17 18:14 mask32.bmp
-rw-r--r-- 1 wfp wfp 61502 2007-03-23 16:03 mask.bmp
wfp@wfp-desktop:~/angband-3.0.8pr2/lib/xtra/graf$
Bill Peterson is offline   Reply With Quote
Old July 7, 2007, 21:05   #10
takkaria
Veteran
 
takkaria's Avatar
 
Join Date: Apr 2007
Posts: 1,858
Donated: $40
takkaria is on a distinguished road
Quote:
Originally Posted by Bill Peterson View Post
I wish it could be so simple. If I've made an error, it's more subtle than that.
Apologies for the presumptious reply -- it was a bug in main-x11. Fixed now. (Will be in the final release.)
takkaria is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with blank walls in Vista Finster Vanilla 77 October 9, 2012 17:15


All times are GMT +1. The time now is 22:10.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.