Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Vanilla

Reply
 
Thread Tools Display Modes
Old May 15, 2013, 20:26   #1
Raajaton
Swordsman
 
Join Date: May 2012
Posts: 289
Raajaton is on a distinguished road
3.5-dev error on startup

Playing the most recent nightly. Whenever I load up my save file I get the following error :

Parse error in \lib\pref\graf-shb.prf line 157 column 5 : unrecognized tval

After the game loads it loads up with tiles, except the player is represented by the @ still. I got this error when I first made this character, switched over to no graphics, which is how I play anyway, and everything was fine. It reverted back to tiles again when loading it up the second time, but it seems I can switch it back to no graphics, and play again as usual.

It also seems that a few of the keybinds I made last play session didn't save, although others did.

Last edited by Raajaton; May 15, 2013 at 21:40.
Raajaton is offline   Reply With Quote
Old May 15, 2013, 21:37   #2
Raajaton
Swordsman
 
Join Date: May 2012
Posts: 289
Raajaton is on a distinguished road
I'm a noob when looking at code, but from what I can tell the tval for iron spikes was removed, but they are still being called in graf-shb.prf which is generating the error.
Raajaton is offline   Reply With Quote
Old May 16, 2013, 01:02   #3
Raajaton
Swordsman
 
Join Date: May 2012
Posts: 289
Raajaton is on a distinguished road
So to satisfy my own curiosity I commented out the line in graf-shb.prf pertaining to the iron spikes. The game then started generating more errors which pointed to line 458 - an empty bottle. It was in a section called "junk" which labeled a bunch of things I hadn't seen before, various types of skulls and skeletons, broken stick, etc. I commented out each of those lines and my save game opens without any errors. It still loads with tiles turned on each time instead of remembering that I had played without graphics enabled, but upon loading with graphics on it actually uses the correct tile for a mage now, instead of displaying the @.
Raajaton is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3.3.0 crash on startup Chud Vanilla 6 September 20, 2011 18:17
Crash on startup (v 3.2 Mac OS X 10.4.11 PPC) Darin Vanilla 3 January 2, 2011 03:05
[O] Error Using Dev-C++ to compile BennyG Variants 8 October 2, 2009 16:51
r1487 startup bug Zikke Development 0 July 8, 2009 15:07
Angband startup trouble. Zambaku Vanilla 1 January 1, 2008 05:43


All times are GMT +1. The time now is 00:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.