Angband.oook.cz
Angband.oook.cz
AboutVariantsLadderForumCompetitionComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Variants

Reply
 
Thread Tools Display Modes
Old September 28, 2009, 21:08   #1
BennyG
Rookie
 
Join Date: Sep 2008
Posts: 7
BennyG is on a distinguished road
[O] Error Using Dev-C++ to compile

Ok, I am a total newb so please forgive me if I am missing something easy.

I just got a copy of Dev-C++ to compile O 1.10u to fix the 'hidden copper/silver/gold' inventory bug. I followed the instructions for angband compiling found http://rephial.org/wiki/Compiling#s2_4

I am getting his error:

584 C:\Dev-Cpp\Projects\oangband110u\src\main.c `modules' undeclared (first use in this function)

Here is the section: (Offending line in red)

#ifndef _WIN32_WCE
/* Print the name and help for each available module */

for (j = 0; j < (int)N_ELEMENTS(modules); j++)
{
printf(" %s %s\n",
modules[j].name, modules[j].help);
}
#endif


Any help would be appreciated.

Thanks,

Ben
BennyG is offline   Reply With Quote
Old September 29, 2009, 11:27   #2
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 55
Posts: 8,338
Donated: $60
Nick will become famous soon enough
Quote:
Originally Posted by BennyG View Post
I just got a copy of Dev-C++ to compile O 1.10u to fix the 'hidden copper/silver/gold' inventory bug. I followed the instructions for angband compiling found http://rephial.org/wiki/Compiling#s2_4
It looks like you have not added the -DWINDOWS to the compiler options (instruction 6).
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is online now   Reply With Quote
Old September 29, 2009, 13:17   #3
BennyG
Rookie
 
Join Date: Sep 2008
Posts: 7
BennyG is on a distinguished road
I double checked. I used the flags exactly as shown on that page.
BennyG is offline   Reply With Quote
Old September 29, 2009, 14:44   #4
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 55
Posts: 8,338
Donated: $60
Nick will become famous soon enough
Odd. The build system for V is different to the O110u one, but this particular problem is hard to understand.

If it's any comfort, I have made a list of things that I need to fix...
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is online now   Reply With Quote
Old September 29, 2009, 15:22   #5
BennyG
Rookie
 
Join Date: Sep 2008
Posts: 7
BennyG is on a distinguished road
Is there a better IDE that I can use, preferably a free one?
BennyG is offline   Reply With Quote
Old September 30, 2009, 02:37   #6
BennyG
Rookie
 
Join Date: Sep 2008
Posts: 7
BennyG is on a distinguished road
On the plus side, I have been playing FAangband since I have been having so much trouble with O.
BennyG is offline   Reply With Quote
Old September 30, 2009, 04:26   #7
Nick
Vanilla maintainer
 
Nick's Avatar
 
Join Date: Apr 2007
Location: Canberra, Australia
Age: 55
Posts: 8,338
Donated: $60
Nick will become famous soon enough
This thread may help you.

Quote:
Originally Posted by BennyG View Post
On the plus side, I have been playing FAangband since I have been having so much trouble with O.
Oops - should have kept my mouth shut...
__________________
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
Nick is online now   Reply With Quote
Old September 30, 2009, 05:20   #8
Pete Mack
Prophet
 
Join Date: Apr 2007
Location: Seattle, WA
Posts: 5,738
Donated: $40
Pete Mack is on a distinguished road
Quote:
Originally Posted by BennyG View Post
Is there a better IDE that I can use, preferably a free one?
You mean like Dev Studio 2008 (express)? Since M$ made its basic IDE free (in 2004), it seems a bit pointless to support after-market developer environments. MinGW/cygwin for basic compilation and devenv.exe for an IDE should be enough.

Last edited by Pete Mack; September 30, 2009 at 05:31.
Pete Mack is offline   Reply With Quote
Old October 2, 2009, 16:51   #9
BennyG
Rookie
 
Join Date: Sep 2008
Posts: 7
BennyG is on a distinguished road
Tried using VS2008 express for c/c++. Got more errors then I did with Dev-c++ and it installed like 8 other useless apps.
Haven't tried eclipse yet.
BennyG is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cygwin 1.7 compile error david3x3x3 Development 0 September 13, 2009 00:03
help with compile error (and "const") will_asher Development 4 August 3, 2009 23:35
1375 parse error PowerDiver Development 12 April 24, 2009 14:48
Compile error - latest Vanilla Angband SVN PaulBlay Development 3 April 19, 2009 21:20
SAngband Error Prismatic Variants 20 May 20, 2008 18:26


All times are GMT +1. The time now is 03:50.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.