Angband.oook.cz
Angband.oook.cz
AboutDownloadVariantsLadderForumCompetitionSpoilersComicScreenshotsFunniesLinks

Go Back   Angband Forums > Angband > Development

Reply
 
Thread Tools Display Modes
Old November 16, 2010, 19:59   #1
ledcraft
Rookie
 
Join Date: Nov 2010
Posts: 3
ledcraft is on a distinguished road
setting a base delay factor causes my game to crash in 3.1.1

has this been fixed?
ledcraft is offline   Reply With Quote
Old November 16, 2010, 22:16   #2
d_m
Angband Devteam member
 
d_m's Avatar
 
Join Date: Aug 2008
Location: Philadelphia, PA, USA
Age: 33
Posts: 1,497
d_m is on a distinguished road
I believe this is fixed; you should try it out and see!
__________________
linux->xterm->screen->pmacs
d_m is offline   Reply With Quote
Old November 16, 2010, 22:42   #3
Derakon
Prophet
 
Derakon's Avatar
 
Join Date: Dec 2009
Posts: 5,814
Derakon is on a distinguished road
I certainly haven't had any issues with delay factors...well, ever! You should try 3.1.2v2, which is the latest stable version (ignore the "beta" label). If you're still having trouble you should let us know what system you have.
Derakon is offline   Reply With Quote
Old November 17, 2010, 01:50   #4
buzzkill
Prophet
 
buzzkill's Avatar
 
Join Date: May 2008
Location: Indiana, USA
Posts: 2,908
Donated: $8
buzzkill is on a distinguished road
I think this came up once before. Making a large change in the setting can make the game appear to 'hang'. Did it crash or just become non-responsive?
__________________
www.mediafire.com/buzzkill - Get your 32x32 tiles here. UT32 now compatible Ironband and Quickband 9/6/2012.
My banding life on Buzzkill's ladder.
buzzkill is offline   Reply With Quote
Old November 17, 2010, 11:08   #5
Nomad
Swordsman
 
Nomad's Avatar
 
Join Date: Sep 2010
Location: England
Posts: 450
Nomad is on a distinguished road
Quote:
Originally Posted by buzzkill View Post
I think this came up once before. Making a large change in the setting can make the game appear to 'hang'. Did it crash or just become non-responsive?
Yeah, that happened to me. I was setting it to run extra slow so I could test out some tile designs, and casually assumed it went up linearly when it's actually squared. Set it to 255 and you end up with 65 seconds between each frame of animation, which seems just a tad excessive. I really think delay_factor should be capped at 63 or even 31 instead - does anyone actually need a frame of animation to hold still for longer than one second?

(Also dangerous: the fact that it doesn't show you that you've set the delay to something stupidly huge unless you hit d to look at it again after you've already confirmed your setting.)
Nomad is offline   Reply With Quote
Old November 17, 2010, 15:30   #6
Derakon
Prophet
 
Derakon's Avatar
 
Join Date: Dec 2009
Posts: 5,814
Derakon is on a distinguished road
That latter point is really annoying, especially since it used to tell you what the actual delay was, in milliseconds. The current system is completely opaque to new users. This doesn't help people find out that Angband has animations at all.

(The delay factor should also default to something nonzero; maybe 4ms)
Derakon is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting traps barna10 Variants 1 August 16, 2010 11:16
game crash on failed lock pick (version 2034) fizzix Development 7 August 7, 2010 20:08
Latest competition savefile and no delay Timo Pietilš Vanilla 2 May 30, 2010 19:22
Setting... Fendell Orcbane AAR 9 May 22, 2010 06:17
Game crash - 3.1.2 Win 7 64 bit kurie Vanilla 4 February 23, 2010 02:37


All times are GMT +1. The time now is 23:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.